aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rtl838x/image/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-11-26 12:02:21 +0100
committerJohn Crispin <john@phrozen.org>2020-11-26 13:29:27 +0100
commit2b88563ee5aafd9571d965b7f2093a0f58d98a31 (patch)
treed2997a6745fe0cffab8db73d4a735c3366a301b0 /target/linux/rtl838x/image/Makefile
parent4e39949dd1f7eb706d857e1c44a992ae752132a7 (diff)
downloadupstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.tar.gz
upstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.tar.bz2
upstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.zip
realtek: update the tree to the latest refactored version
* rename the target to realtek * add refactored DSA driver * add latest gpio driver * lots of arch cleanups * new irq driver * additional boards Signed-off-by: Bert Vermeulen <bert@biot.com> Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> Signed-off-by: Sander Vanheule <sander@svanheule.net> Signed-off-by: Bjørn Mork <bjorn@mork.no> Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/rtl838x/image/Makefile')
-rw-r--r--target/linux/rtl838x/image/Makefile58
1 files changed, 0 insertions, 58 deletions
diff --git a/target/linux/rtl838x/image/Makefile b/target/linux/rtl838x/image/Makefile
deleted file mode 100644
index 266759220f..0000000000
--- a/target/linux/rtl838x/image/Makefile
+++ /dev/null
@@ -1,58 +0,0 @@
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/image.mk
-
-KERNEL_LOADADDR = 0x80000000
-KERNEL_ENTRY = 0x80000400
-
-define Device/Default
- PROFILES = Default
- KERNEL := kernel-bin | append-dtb | gzip | uImage gzip
- KERNEL_INITRAMFS := kernel-bin | append-dtb | gzip | uImage gzip
- DEVICE_DTS_DIR := ../dts
- DEVICE_DTS = $$(SOC)_$(1)
- SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
- IMAGES := sysupgrade.bin
- IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | \
- append-metadata | check-size
-endef
-
-define Device/allnet_all-sg8208m
- SOC := rtl8382
- IMAGE_SIZE := 7168k
- DEVICE_VENDOR := ALLNET
- DEVICE_MODEL := ALL-SG8208M
- UIMAGE_MAGIC := 0x00000006
- UIMAGE_NAME := 2.2.2.0
- DEVICE_PACKAGES := ip-full ip-bridge kmod-gpio-button-hotplug tc
-endef
-TARGET_DEVICES += allnet_all-sg8208m
-
-define Device/d-link_dgs-1210
- SOC := rtl8382
- IMAGE_SIZE := 13824k
- DEVICE_VENDOR := D-Link
- DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
-endef
-
-define Device/d-link_dgs-1210-10p
- $(Device/d-link_dgs-1210)
- DEVICE_MODEL := DGS-1210-10P
- DEVICE_PACKAGES += lua-rs232
-endef
-TARGET_DEVICES += d-link_dgs-1210-10p
-
-define Device/d-link_dgs-1210-16
- $(Device/d-link_dgs-1210)
- DEVICE_MODEL := DGS-1210-16
-endef
-TARGET_DEVICES += d-link_dgs-1210-16
-
-define Device/d-link_dgs-1210-28
- $(Device/d-link_dgs-1210)
- DEVICE_MODEL := DGS-1210-28
-endef
-TARGET_DEVICES += d-link_dgs-1210-28
-$(eval $(call BuildImage))