aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2020-07-11 14:02:23 +0200
committerDavid Bauer <mail@david-bauer.net>2020-07-28 15:52:44 +0200
commitb72f7c64a4eb4aa14f3b632dd4ff77a4802c0311 (patch)
tree08d6a68cd910987f1f91cc655951e5796c6309d5 /target/linux/rockchip
parentc3e252d08032de80e7c82759cc9763a310a97144 (diff)
downloadupstream-b72f7c64a4eb4aa14f3b632dd4ff77a4802c0311.tar.gz
upstream-b72f7c64a4eb4aa14f3b632dd4ff77a4802c0311.tar.bz2
upstream-b72f7c64a4eb4aa14f3b632dd4ff77a4802c0311.zip
rockchip: allow for multiple boot-scripts
Add support for select a bootscript depending on the device built. This is necessary, as the FriendlyARM NanoPi R2S needs a different bootcmd in order to produce output on the debug UART. Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/rockchip')
-rw-r--r--target/linux/rockchip/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/rockchip/image/Makefile b/target/linux/rockchip/image/Makefile
index 22854d9d02..3c17e963be 100644
--- a/target/linux/rockchip/image/Makefile
+++ b/target/linux/rockchip/image/Makefile
@@ -24,7 +24,7 @@ endef
define Build/boot-script
# Make an U-boot image and copy it to the boot partition
- mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d mmc.bootscript $@.boot/boot.scr
+ mkimage -A arm -O linux -T script -C none -a 0 -e 0 -d $(if $(1),$(1),mmc).bootscript $@.boot/boot.scr
endef
define Build/pine64-img