aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rockchip/image
diff options
context:
space:
mode:
authorTianling Shen <cnsztl@immortalwrt.org>2023-05-30 12:59:07 +0800
committerHauke Mehrtens <hauke@hauke-m.de>2023-06-09 13:15:19 +0200
commitc11115b5cff2b67ee73da50d864e6443e7124812 (patch)
tree88d690094078277861cf8ddb34dcfe0c276a716b /target/linux/rockchip/image
parentecfcc47f0ce5333eda3149ea2e3f1d2c25bd9455 (diff)
downloadupstream-c11115b5cff2b67ee73da50d864e6443e7124812.tar.gz
upstream-c11115b5cff2b67ee73da50d864e6443e7124812.tar.bz2
upstream-c11115b5cff2b67ee73da50d864e6443e7124812.zip
rockchip: add Orange Pi R1 Plus support
Orange Pi R1 Plus is a Rockchip RK3328 based SBC by Xunlong. This device is similar to the NanoPi R2S, and has a 16MB SPI NOR (mx25l12805d). The reset button is changed to directly reset the power supply, another detail is that both network ports have independent MAC addresses. Note: booting from SPI is currently unsupported, you have to install the image on a SD card. Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org> (cherry picked from commit ab641efe698f4412319fcbcfe6ffde64c929cd97) [Removed patches for kernel 6.1] Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
Diffstat (limited to 'target/linux/rockchip/image')
-rw-r--r--target/linux/rockchip/image/armv8.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/rockchip/image/armv8.mk b/target/linux/rockchip/image/armv8.mk
index 601ddcbdd6..9a32a07b21 100644
--- a/target/linux/rockchip/image/armv8.mk
+++ b/target/linux/rockchip/image/armv8.mk
@@ -60,3 +60,12 @@ define Device/radxa_rock-pi-4a
IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
endef
TARGET_DEVICES += radxa_rock-pi-4a
+
+define Device/xunlong_orangepi-r1-plus
+ DEVICE_VENDOR := Xunlong
+ DEVICE_MODEL := Orange Pi R1 Plus
+ SOC := rk3328
+ IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
+ DEVICE_PACKAGES := kmod-usb-net-rtl8152
+endef
+TARGET_DEVICES += xunlong_orangepi-r1-plus