aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek
diff options
context:
space:
mode:
authorMichael Mohr <akihana@gmail.com>2021-01-08 21:21:15 -0800
committerPetr Štetiar <ynezz@true.cz>2021-02-12 08:52:41 +0100
commit9877393fd135f247f58bd4dc6f1532f77f1c40c8 (patch)
tree4342cfa595bc4577539ae04528d921600081ec41 /target/linux/realtek
parent14b9100f1c6e4b403270fb2e285daa9d130e4cfd (diff)
downloadupstream-9877393fd135f247f58bd4dc6f1532f77f1c40c8.tar.gz
upstream-9877393fd135f247f58bd4dc6f1532f77f1c40c8.tar.bz2
upstream-9877393fd135f247f58bd4dc6f1532f77f1c40c8.zip
realtek: add and use netgear_nge for the GS110PP v1
The netgear_nge device will be shared between the GS108T v3 (to be added in a later commit) and the GS110PP v1. It also enables LZMA compression for the ramdisk image. Signed-off-by: Michael Mohr <akihana@gmail.com>
Diffstat (limited to 'target/linux/realtek')
-rw-r--r--target/linux/realtek/image/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/target/linux/realtek/image/Makefile b/target/linux/realtek/image/Makefile
index 29350d8ae5..c875aca2a6 100644
--- a/target/linux/realtek/image/Makefile
+++ b/target/linux/realtek/image/Makefile
@@ -25,6 +25,16 @@ define Device/Default
append-metadata | check-size
endef
+# "NGE" refers to the uImage magic
+define Device/netgear_nge
+ KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+ KERNEL_INITRAMFS := kernel-bin | append-dtb | lzma | uImage lzma
+ SOC := rtl8380
+ IMAGE_SIZE := 14848k
+ UIMAGE_MAGIC := 0x4e474520
+ DEVICE_VENDOR := NETGEAR
+endef
+
define Device/allnet_all-sg8208m
SOC := rtl8382
IMAGE_SIZE := 7168k
@@ -61,12 +71,8 @@ endef
TARGET_DEVICES += d-link_dgs-1210-28
define Device/netgear_gs110tpp-v1
- $(Device/Default)
- SOC := rtl8380
- IMAGE_SIZE := 14848k
- UIMAGE_MAGIC := 0x4e474520
- DEVICE_VENDOR := NETGEAR
- DEVICE_MODEL := GS110TP
+ $(Device/netgear_nge)
+ DEVICE_MODEL := GS110TPP
DEVICE_VARIANT := v1
endef
TARGET_DEVICES += netgear_gs110tpp-v1