aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek
diff options
context:
space:
mode:
authorJohn Audia <graysky@archlinux.us>2021-01-27 09:41:12 -0500
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-29 14:22:09 +0100
commit2c35899d8196c3c4f02c9b788b99a8a3bbbb32d1 (patch)
treed7c1428523fa035cd8df33db81044878ea871354 /target/linux/realtek
parent7d12f29ae1d7337e4289baf9e6b4bf79445b0d59 (diff)
downloadupstream-2c35899d8196c3c4f02c9b788b99a8a3bbbb32d1.tar.gz
upstream-2c35899d8196c3c4f02c9b788b99a8a3bbbb32d1.tar.bz2
upstream-2c35899d8196c3c4f02c9b788b99a8a3bbbb32d1.zip
kernel: bump 5.4 to 5.4.93
All modification made by update_kernel.sh in a fresh clone without existing toolchains. Build system: x86_64 Build-tested: ipq806x/R7800, bcm27xx/bcm2711 Run-tested: ipq806x/R7800 Compile-tested [*]: ath79/{tiny,generic}, ipq40xx, octeon, ramips/mt7621, realtek, x86/64 Run-tested [*]: ath79/generic, ipq40xx, octeon, ramips/mt7621 No dmesg regressions, everything functional Signed-off-by: John Audia <graysky@archlinux.us> Tested-by: Stijn Segers <foss@volatilesystems.org> [*]
Diffstat (limited to 'target/linux/realtek')
-rw-r--r--target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch6
-rw-r--r--target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch2
2 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch b/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
index 763f6adc58..8359dfdcbc 100644
--- a/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
+++ b/target/linux/realtek/patches-5.4/302-clocksource-add-rtl9300-driver.patch
@@ -1,6 +1,6 @@
--- a/drivers/clocksource/Kconfig
+++ b/drivers/clocksource/Kconfig
-@@ -126,6 +126,15 @@
+@@ -126,6 +126,15 @@ config RDA_TIMER
help
Enables the support for the RDA Micro timer driver.
@@ -16,7 +16,7 @@
config SUN4I_TIMER
bool "Sun4i timer driver" if COMPILE_TEST
depends on HAS_IOMEM
-@@ -695,5 +704,4 @@
+@@ -695,5 +704,4 @@ config INGENIC_TIMER
select IRQ_DOMAIN
help
Support for the timer/counter unit of the Ingenic JZ SoCs.
@@ -24,7 +24,7 @@
endmenu
--- a/drivers/clocksource/Makefile
+++ b/drivers/clocksource/Makefile
-@@ -61,6 +61,7 @@
+@@ -61,6 +61,7 @@ obj-$(CONFIG_MILBEAUT_TIMER) += timer-mi
obj-$(CONFIG_SPRD_TIMER) += timer-sprd.o
obj-$(CONFIG_NPCM7XX_TIMER) += timer-npcm7xx.o
obj-$(CONFIG_RDA_TIMER) += timer-rda.o
diff --git a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch b/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
index 7bfbd0a5f6..803614e7c0 100644
--- a/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
+++ b/target/linux/realtek/patches-5.4/701-net-dsa-add-rtl838x-support-for-tag-trailer.patch
@@ -13,7 +13,7 @@
trailer[2] = 0x10;
trailer[3] = 0x00;
-@@ -61,12 +69,23 @@ static struct sk_buff *trailer_rcv(struc
+@@ -61,12 +66,23 @@ static struct sk_buff *trailer_rcv(struc
return NULL;
trailer = skb_tail_pointer(skb) - 4;