aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/realtek/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2020-11-26 12:02:21 +0100
committerJohn Crispin <john@phrozen.org>2020-11-26 13:29:27 +0100
commit2b88563ee5aafd9571d965b7f2093a0f58d98a31 (patch)
treed2997a6745fe0cffab8db73d4a735c3366a301b0 /target/linux/realtek/Makefile
parent4e39949dd1f7eb706d857e1c44a992ae752132a7 (diff)
downloadupstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.tar.gz
upstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.tar.bz2
upstream-2b88563ee5aafd9571d965b7f2093a0f58d98a31.zip
realtek: update the tree to the latest refactored version
* rename the target to realtek * add refactored DSA driver * add latest gpio driver * lots of arch cleanups * new irq driver * additional boards Signed-off-by: Bert Vermeulen <bert@biot.com> Signed-off-by: Birger Koblitz <mail@birger-koblitz.de> Signed-off-by: Sander Vanheule <sander@svanheule.net> Signed-off-by: Bjørn Mork <bjorn@mork.no> Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/realtek/Makefile')
-rw-r--r--target/linux/realtek/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/realtek/Makefile b/target/linux/realtek/Makefile
new file mode 100644
index 0000000000..98fcaf3968
--- /dev/null
+++ b/target/linux/realtek/Makefile
@@ -0,0 +1,27 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+CPU_TYPE:=4kec
+BOARD:=realtek
+BOARDNAME:=Realtek MIPS
+DEVICE_TYPE:=basic
+FEATURES:=ramdisk squashfs
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=5.4
+
+define Target/Description
+ Build firmware images for Realtek RTL83xx based boards.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+FEATURES := $(filter-out mips16,$(FEATURES))
+
+DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
+ dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
+
+$(eval $(call BuildTarget))