aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 13:34:51 +0000
commitae9b96421b595a0d6113d87a4d2ddd73f81d5582 (patch)
treed6411eb2068038b1c0b39c047f3ffa41486f9132 /target/linux/rdc
parentd6be1ff0d27ceb059493222ecad2a39660d88e30 (diff)
downloadupstream-ae9b96421b595a0d6113d87a4d2ddd73f81d5582.tar.gz
upstream-ae9b96421b595a0d6113d87a4d2ddd73f81d5582.tar.bz2
upstream-ae9b96421b595a0d6113d87a4d2ddd73f81d5582.zip
package/kernel: move target specific modules to their own target files
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21132 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/rdc')
-rw-r--r--target/linux/rdc/modules.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/rdc/modules.mk b/target/linux/rdc/modules.mk
index e69de29bb2..bb4c0cbe4e 100644
--- a/target/linux/rdc/modules.mk
+++ b/target/linux/rdc/modules.mk
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define KernelPackage/rdc321x-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=RDC321x watchdog
+ DEPENDS:=@TARGET_rdc
+ KCONFIG:=CONFIG_RDC321X_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/rdc321x_wdt.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,rdc321x_wdt)
+endef
+
+define KernelPackage/rdc321x-wdt/description
+ RDC-321x watchdog driver
+endef
+
+$(eval $(call KernelPackage,rdc321x-wdt))
+