aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-25 10:13:00 +0000
commit821bd49569acf55cc6489c762dc279f6da838dee (patch)
tree397901ecc16c129354cb037dac2ea1833855bdcb /target/linux/rdc/profiles
parent35bb7be34d30252059144c1855f7397695b9362c (diff)
downloadupstream-821bd49569acf55cc6489c762dc279f6da838dee.tar.gz
upstream-821bd49569acf55cc6489c762dc279f6da838dee.tar.bz2
upstream-821bd49569acf55cc6489c762dc279f6da838dee.zip
use profiles again intead of subtargets.
We have now a single kernel which autodetects the type of device we are running on, so we can switch back to having profiles. Patch by Bernhard Loos. SVN-Revision: 20416
Diffstat (limited to 'target/linux/rdc/profiles')
-rw-r--r--target/linux/rdc/profiles/ar525w.mk12
-rw-r--r--target/linux/rdc/profiles/bifferboard.mk11
-rw-r--r--target/linux/rdc/profiles/r8610.mk15
-rw-r--r--target/linux/rdc/profiles/sitecom.mk12
4 files changed, 50 insertions, 0 deletions
diff --git a/target/linux/rdc/profiles/ar525w.mk b/target/linux/rdc/profiles/ar525w.mk
new file mode 100644
index 0000000000..c2faee9da6
--- /dev/null
+++ b/target/linux/rdc/profiles/ar525w.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/ar525w
+ NAME:=Airlink AR525W
+ PACKAGES:=kmod-rt61-pci
+endef
+$(eval $(call Profile,ar525w))
diff --git a/target/linux/rdc/profiles/bifferboard.mk b/target/linux/rdc/profiles/bifferboard.mk
new file mode 100644
index 0000000000..0c12ac77f7
--- /dev/null
+++ b/target/linux/rdc/profiles/bifferboard.mk
@@ -0,0 +1,11 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/bifferboard
+ NAME:=Bifferboard
+endef
+$(eval $(call Profile,bifferboard))
diff --git a/target/linux/rdc/profiles/r8610.mk b/target/linux/rdc/profiles/r8610.mk
new file mode 100644
index 0000000000..67fef8a5ae
--- /dev/null
+++ b/target/linux/rdc/profiles/r8610.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/r8610
+ NAME:=RDC R8610 Evaluation Board
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
+ kmod-hwmon-core kmod-hwmon-w83627hf kmod-ide-core kmod-ide-it821x \
+ kmod-rtc-core kmod-rtc-m48t86 \
+ kmod-fs-ext2 kmod-fs-ext3
+endef
+$(eval $(call Profile,r8610))
diff --git a/target/linux/rdc/profiles/sitecom.mk b/target/linux/rdc/profiles/sitecom.mk
new file mode 100644
index 0000000000..e3b2981ed8
--- /dev/null
+++ b/target/linux/rdc/profiles/sitecom.mk
@@ -0,0 +1,12 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/sitecom
+ NAME:=Devices from Sitecom (WL-153, DC-230)
+ PACKAGES:=kmod-rt61-pci kmod-usb-core kmod-usb-ohci kmod-usb2
+endef
+$(eval $(call Profile,sitecom))