aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc/patches-2.6.32/100-rdc_boards.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-04-28 13:55:11 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-04-28 13:55:11 +0000
commit14fd2f20f811c4cf72abc6988efef62568dfade2 (patch)
tree96308cbfcb73ea86949d5524649a7a336e56460c /target/linux/rdc/patches-2.6.32/100-rdc_boards.patch
parent73e450f44a9fe3e5ad1dcd7e6a95eb48f9082aa5 (diff)
downloadupstream-14fd2f20f811c4cf72abc6988efef62568dfade2.tar.gz
upstream-14fd2f20f811c4cf72abc6988efef62568dfade2.tar.bz2
upstream-14fd2f20f811c4cf72abc6988efef62568dfade2.zip
panic on unrecovered NMI, thanks rtz2
SVN-Revision: 21232
Diffstat (limited to 'target/linux/rdc/patches-2.6.32/100-rdc_boards.patch')
-rw-r--r--target/linux/rdc/patches-2.6.32/100-rdc_boards.patch48
1 files changed, 16 insertions, 32 deletions
diff --git a/target/linux/rdc/patches-2.6.32/100-rdc_boards.patch b/target/linux/rdc/patches-2.6.32/100-rdc_boards.patch
index e88e6ee853..0b8446c824 100644
--- a/target/linux/rdc/patches-2.6.32/100-rdc_boards.patch
+++ b/target/linux/rdc/patches-2.6.32/100-rdc_boards.patch
@@ -1,17 +1,13 @@
-Index: linux-2.6.32.10/arch/x86/mach-rdc321x/Makefile
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/mach-rdc321x/Makefile 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/mach-rdc321x/Makefile
@@ -0,0 +1,5 @@
+#
+# Makefile for the RDC321x specific parts of the kernel
+#
+obj-$(CONFIG_X86_RDC321X) := platform.o reboot.o boards/sitecom.o boards/ar525w.o boards/bifferboard.o boards/r8610.o
+
-Index: linux-2.6.32.10/arch/x86/mach-rdc321x/platform.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/mach-rdc321x/platform.c 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/mach-rdc321x/platform.c
@@ -0,0 +1,115 @@
+/*
+ * Generic RDC321x platform devices
@@ -128,10 +124,8 @@ Index: linux-2.6.32.10/arch/x86/mach-rdc321x/platform.c
+ return platform_add_devices(rdc321x_devs, ARRAY_SIZE(rdc321x_devs));
+}
+late_initcall(rdc_board_setup);
-Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/ar525w.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/mach-rdc321x/boards/ar525w.c 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/mach-rdc321x/boards/ar525w.c
@@ -0,0 +1,243 @@
+/*
+ * ar525w RDC321x platform devices
@@ -376,10 +370,8 @@ Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/ar525w.c
+}
+
+arch_initcall(ar525w_setup);
-Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/bifferboard.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/mach-rdc321x/boards/bifferboard.c 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/mach-rdc321x/boards/bifferboard.c
@@ -0,0 +1,81 @@
+/*
+ * Bifferboard RDC321x platform devices
@@ -462,10 +454,8 @@ Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/bifferboard.c
+ return register_mtd_parser(&bifferboard_parser);
+}
+arch_initcall(bifferboard_setup);
-Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/r8610.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/mach-rdc321x/boards/r8610.c 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/mach-rdc321x/boards/r8610.c
@@ -0,0 +1,65 @@
+/*
+ * R8610 RDC321x platform devices
@@ -532,10 +522,8 @@ Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/r8610.c
+}
+
+arch_initcall(r8610_setup);
-Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/sitecom.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/mach-rdc321x/boards/sitecom.c 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/mach-rdc321x/boards/sitecom.c
@@ -0,0 +1,111 @@
+/*
+ * Sitecom RDC321x platform devices
@@ -648,10 +636,8 @@ Index: linux-2.6.32.10/arch/x86/mach-rdc321x/boards/sitecom.c
+}
+
+arch_initcall(sitecom_setup);
-Index: linux-2.6.32.10/arch/x86/mach-rdc321x/reboot.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/mach-rdc321x/reboot.c 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/mach-rdc321x/reboot.c
@@ -0,0 +1,44 @@
+/*
+ * This program is free software; you can redistribute it and/or
@@ -697,10 +683,8 @@ Index: linux-2.6.32.10/arch/x86/mach-rdc321x/reboot.c
+}
+
+arch_initcall(rdc_setup_reset);
-Index: linux-2.6.32.10/arch/x86/include/asm/rdc_boards.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.32.10/arch/x86/include/asm/rdc_boards.h 2010-04-28 11:39:32.000000000 +0200
+--- /dev/null
++++ b/arch/x86/include/asm/rdc_boards.h
@@ -0,0 +1,36 @@
+/*
+ * RDC321x boards