aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/patches
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-09 08:13:58 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-09 08:13:58 +0000
commit8ff49aed398fe2682088d02f38838d703ced0746 (patch)
treeb81d8906856e62e657747c53d4ee08b1eabb70dd /target/linux/rdc-2.6/patches
parentb5a6f01ec053aee4ad078eb523c0ed7e2f22cbfc (diff)
downloadupstream-8ff49aed398fe2682088d02f38838d703ced0746.tar.gz
upstream-8ff49aed398fe2682088d02f38838d703ced0746.tar.bz2
upstream-8ff49aed398fe2682088d02f38838d703ced0746.zip
Fresh fixes for rdc from sn9, thanks !
SVN-Revision: 6911
Diffstat (limited to 'target/linux/rdc-2.6/patches')
-rw-r--r--target/linux/rdc-2.6/patches/000-rdc_fixes.patch2
-rw-r--r--target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch56
-rw-r--r--target/linux/rdc-2.6/patches/003-rootfstype.patch22
3 files changed, 64 insertions, 16 deletions
diff --git a/target/linux/rdc-2.6/patches/000-rdc_fixes.patch b/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
index 7d6fa3af32..140cde9a9b 100644
--- a/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
+++ b/target/linux/rdc-2.6/patches/000-rdc_fixes.patch
@@ -26,7 +26,7 @@ diff -urN linux-2.6.19/arch/i386/Makefile linux-2.6.19.new/arch/i386/Makefile
+# RDC subarch support
+mflags-$(CONFIG_X86_RDC) := -Iinclude/asm-i386/mach-generic
+mcore-$(CONFIG_X86_RDC) := mach-default
-+core-$(CONFIG_X86_RDC) := arch/i386/mach-rdc/
++core-$(CONFIG_X86_RDC) += arch/i386/mach-rdc/
# default subarch .h files
mflags-y += -Iinclude/asm-i386/mach-default
diff --git a/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch b/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch
index 7411f06816..0c407a114a 100644
--- a/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch
+++ b/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch
@@ -1,7 +1,7 @@
diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/maps/Kconfig
--- linux-2.6.17/drivers/mtd/maps/Kconfig 2006-06-18 03:49:35.000000000 +0200
+++ linux-2.6.17.new/drivers/mtd/maps/Kconfig 2006-09-24 20:28:11.000000000 +0200
-@@ -76,6 +76,12 @@
+@@ -76,6 +76,50 @@
PNC-2000 is the name of Network Camera product from PHOTRON
Ltd. in Japan. It uses CFI-compliant flash.
@@ -9,11 +9,49 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Kconfig linux-2.6.17.new/drivers/mtd/map
+ tristate "CFI Flash device mapped on RDC3210"
+ depends on X86 && MTD_CFI && MTD_PARTITIONS
+ help
-+ RDC-3210 is the flash device we find on Ralink reference board
++ RDC-3210 is the flash device we find on Ralink reference board.
++
++config MTD_RDC3210_STATIC_MAP
++ bool "Partitions on RDC3210 mapped statically" if MTD_RDC3210
++ select MTD_RDC3210_FACTORY_PRESENT
++ help
++ The mapping driver will use the static partition map for the
++ RDC-3210 flash device.
++
++config MTD_RDC3210_FACTORY_PRESENT
++ bool "Reserve a partition on RDC3210 for factory presets"
++ depends on MTD_RDC3210
++ default y
++ help
++ The mapping driver will reserve a partition on the RDC-3210 flash
++ device for resetting flash contents to factory defaults.
++
++config MTD_RDC3210_ALLOW_JFFS2
++ bool "JFFS2 filesystem usable in a partition on RDC3210"
++ depends on MTD_RDC3210 && !MTD_RDC3210_STATIC_MAP
++ help
++ The mapping driver will align a partition on the RDC-3210 flash
++ device to an erase-block boundary so that a JFFS2 filesystem may
++ reside on it.
++
++config MTD_RDC3210_SIZE
++ hex "Amount of flash memory on RDC3210"
++ depends on MTD_RDC3210
++ default "0x400000"
++ help
++ Total size in bytes of the RDC-3210 flash device
++
++config MTD_RDC3210_BUSWIDTH
++ int "Width of CFI Flash device mapped on RDC3210"
++ depends on MTD_RDC3210
++ default "2"
++ help
++ Number of bytes addressed on the RDC-3210 flash device before
++ addressing the same chip again
+
config MTD_SC520CDP
tristate "CFI Flash device mapped on AMD SC520 CDP"
- depends on X86 && MTD_CFI
+ depends on X86 && MTD_CFI && MTD_CONCAT
diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/maps/Makefile
--- linux-2.6.17/drivers/mtd/maps/Makefile 2006-06-18 03:49:35.000000000 +0200
+++ linux-2.6.17.new/drivers/mtd/maps/Makefile 2006-09-24 20:26:10.000000000 +0200
@@ -25,15 +63,3 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/ma
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
-diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboot.c
---- linux-2.6.19/drivers/mtd/redboot.c 2006-12-18 17:09:14.000000000 +0100
-+++ linux-2.6.19.new/drivers/mtd/redboot.c 2006-12-18 17:14:26.000000000 +0100
-@@ -39,7 +39,7 @@
- return 1;
- }
-
--static int parse_redboot_partitions(struct mtd_info *master,
-+int parse_redboot_partitions(struct mtd_info *master,
- struct mtd_partition **pparts,
- unsigned long fis_origin)
- {
diff --git a/target/linux/rdc-2.6/patches/003-rootfstype.patch b/target/linux/rdc-2.6/patches/003-rootfstype.patch
new file mode 100644
index 0000000000..c0ac6ad3db
--- /dev/null
+++ b/target/linux/rdc-2.6/patches/003-rootfstype.patch
@@ -0,0 +1,22 @@
+--- linux-2.6.19.2/init/do_mounts.c 2007-01-10 11:10:37.000000000 -0800
++++ foo/init/do_mounts.c 2007-04-05 13:15:37.000000000 -0700
+@@ -243,6 +243,8 @@
+ {
+ char *s = page;
+
++ if (!root_fs_names)
++ root_fs_names = "squashfs,jffs2";
+ if (root_fs_names) {
+ strcpy(page, root_fs_names);
+ while (*s++) {
+--- linux-2.6.19.2/init/do_mounts.c 2007-01-10 11:10:37.000000000 -0800
++++ foo/init/do_mounts.c 2007-04-05 13:15:37.000000000 -0700
+@@ -243,6 +243,8 @@
+ {
+ char *s = page;
+
++ if (!root_fs_names)
++ root_fs_names = "squashfs,jffs2";
+ if (root_fs_names) {
+ strcpy(page, root_fs_names);
+ while (*s++) {