aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rdc-2.6/patches
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-01 09:47:27 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-01 09:47:27 +0000
commit3e6bb28214c639e40cfd02d2525392f804721cd8 (patch)
tree19837e78062dba307f189b0200a1918342332615 /target/linux/rdc-2.6/patches
parentc3697977ab71c0713010925c721b9d826aa155c5 (diff)
downloadupstream-3e6bb28214c639e40cfd02d2525392f804721cd8.tar.gz
upstream-3e6bb28214c639e40cfd02d2525392f804721cd8.tar.bz2
upstream-3e6bb28214c639e40cfd02d2525392f804721cd8.zip
the redboot parsing function needs to be exported
SVN-Revision: 6778
Diffstat (limited to 'target/linux/rdc-2.6/patches')
-rw-r--r--target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch b/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch
index b3a4adb00d..7411f06816 100644
--- a/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch
+++ b/target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch
@@ -25,3 +25,15 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/ma
obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
+diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboot.c
+--- linux-2.6.19/drivers/mtd/redboot.c 2006-12-18 17:09:14.000000000 +0100
++++ linux-2.6.19.new/drivers/mtd/redboot.c 2006-12-18 17:14:26.000000000 +0100
+@@ -39,7 +39,7 @@
+ return 1;
+ }
+
+-static int parse_redboot_partitions(struct mtd_info *master,
++int parse_redboot_partitions(struct mtd_info *master,
+ struct mtd_partition **pparts,
+ unsigned long fis_origin)
+ {