aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-19 14:53:24 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-19 14:53:24 +0000
commitcfddec3e1d3b45582909d6dd39f7dddb4ea0c459 (patch)
tree267c056145bc54e1ac156b18628a3d4a32254dd7 /target/linux/rb532-2.6/image/Makefile
parent90e990be2be137d5155b21a7f2476817569d3fc8 (diff)
downloadupstream-cfddec3e1d3b45582909d6dd39f7dddb4ea0c459.tar.gz
upstream-cfddec3e1d3b45582909d6dd39f7dddb4ea0c459.tar.bz2
upstream-cfddec3e1d3b45582909d6dd39f7dddb4ea0c459.zip
Convert the NAND driver to platform_driver, allow tgz image to be built correctly
SVN-Revision: 8058
Diffstat (limited to 'target/linux/rb532-2.6/image/Makefile')
-rw-r--r--target/linux/rb532-2.6/image/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 555eb2a645..a9e2b9575c 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -49,9 +49,16 @@ define Image/cmdline/squashfs
block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
endef
+# TGZ images should be used with a yaffs2 rootfs
+define Image/cmdline/tgz
+root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+endef
+
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/$(1))) '
+ifneq ($(1),tgz)
./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
+endif
endef
$(eval $(call BuildImage))