aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/image/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-07 00:26:26 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-07 00:26:26 +0000
commitcf52f51b85f1366f0124dda81e75b87badb13c50 (patch)
tree7a5a30118358684a78a0aa5432826a357249890c /target/linux/rb532-2.6/image/Makefile
parenta1e679979795d56cae454b51145ed09e0b8a0a89 (diff)
downloadupstream-cf52f51b85f1366f0124dda81e75b87badb13c50.tar.gz
upstream-cf52f51b85f1366f0124dda81e75b87badb13c50.tar.bz2
upstream-cf52f51b85f1366f0124dda81e75b87badb13c50.zip
remove custom partition table hack, add ptgen utility for generating partition tables
SVN-Revision: 5704
Diffstat (limited to 'target/linux/rb532-2.6/image/Makefile')
-rw-r--r--target/linux/rb532-2.6/image/Makefile16
1 files changed, 1 insertions, 15 deletions
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 4907214469..1f3a88ba40 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -39,9 +39,6 @@ define Image/BuildKernel
$(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
endef
-PARTITION1=\x80\x01\x01\x00\x27\x01\x20\x7b\x20\x00\x00\x00\xe0\x1e\x00\x00# 4 MB (kernel part)
-PARTITION2=\x00\x00\x01\x7c\x83\x01\xa0\x64\x00\x1f\x00\x00\x40\x7a\x00\x00# 16 MB (rootfs part)
-
define Image/cmdline/jffs2-64k
block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=jffs2
endef
@@ -56,18 +53,7 @@ endef
define Image/Build
$(STAGING_DIR)/bin/patch-cmdline $(LINUX_DIR)/vmlinux '$(strip $(call Image/cmdline/$(1))) '
- ( \
- echo -ne OWRT | dd bs=$$$$((0x1be)) conv=sync; \
- ( \
- echo -ne '$(strip $(PARTITION1))'; \
- echo -ne '$(strip $(PARTITION2))'; \
- ) | dd bs=$$$$((0x40)) conv=sync; \
- echo -ne '\x55\xaa'; \
- dd if=/dev/zero bs=$$$$((0x3e00)) conv=sync count=1; \
- dd if=$(LINUX_DIR)/vmlinux bs=$$$$((0x3dc000)) conv=sync; \
- cat $(KDIR)/root.$(1); \
- echo -ne '\xde\xad\xc0\xde'; \
- ) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin
+ ./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(LINUX_DIR)/vmlinux 16 $(KDIR)/root.$(1)
endef
$(eval $(call BuildImage))