aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb532-2.6/image/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-07-20 14:33:15 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-07-20 14:33:15 +0000
commit56d235dfb7ea4975dba870c5753805e658bce8b3 (patch)
tree85ca14b00d87499031dcb08885d85e57f79495c3 /target/linux/rb532-2.6/image/Makefile
parentae7bf3d0f0a9fbf008a2cb16e089206f02c0cd66 (diff)
downloadupstream-56d235dfb7ea4975dba870c5753805e658bce8b3.tar.gz
upstream-56d235dfb7ea4975dba870c5753805e658bce8b3.tar.bz2
upstream-56d235dfb7ea4975dba870c5753805e658bce8b3.zip
compress the kernel that resides on the nand memory
SVN-Revision: 8073
Diffstat (limited to 'target/linux/rb532-2.6/image/Makefile')
-rw-r--r--target/linux/rb532-2.6/image/Makefile14
1 files changed, 12 insertions, 2 deletions
diff --git a/target/linux/rb532-2.6/image/Makefile b/target/linux/rb532-2.6/image/Makefile
index 6e2319c5fb..3cdba39432 100644
--- a/target/linux/rb532-2.6/image/Makefile
+++ b/target/linux/rb532-2.6/image/Makefile
@@ -49,8 +49,7 @@ define Image/cmdline/squashfs
block2mtd.block2mtd=/dev/cfa2,65536 root=/dev/mtdblock0 rootfstype=squashfs init=/etc/preinit
endef
-# TGZ images should be used with a yaffs2 rootfs
-define Image/cmdline/tgz
+define Image/cmdline/yaffs2
root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
endef
@@ -59,4 +58,15 @@ define Image/Build
./gen_image.sh $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).bin 4 $(KDIR)/vmlinux.elf $(CONFIG_TARGET_ROOTFS_FSPART) $(KDIR)/root.$(1)
endef
+ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
+ define Image/Prepare
+ $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux '$(strip $(call Image/cmdline/yaffs2)) '
+ cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
+ $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+ endef
+ define Image/BuildKernel
+ $(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
+ endef
+endif
+
$(eval $(call BuildImage))