aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/rb1xx-2.6/profiles
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-04-02 16:59:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-04-02 16:59:59 +0000
commit3e8d73d762c0e473bcfa49dbdc488b48ba57e06a (patch)
tree49b3d3f10ddedb39df71c2cdac6b597d2115a6cc /target/linux/rb1xx-2.6/profiles
parent75262124ba989c05a5840d8ad878429589e68249 (diff)
downloadupstream-3e8d73d762c0e473bcfa49dbdc488b48ba57e06a.tar.gz
upstream-3e8d73d762c0e473bcfa49dbdc488b48ba57e06a.tar.bz2
upstream-3e8d73d762c0e473bcfa49dbdc488b48ba57e06a.zip
Add preliminary RouterBoard RB1xx support
SVN-Revision: 6839
Diffstat (limited to 'target/linux/rb1xx-2.6/profiles')
-rw-r--r--target/linux/rb1xx-2.6/profiles/100-Atheros.mk17
-rw-r--r--target/linux/rb1xx-2.6/profiles/105-Texas.mk17
-rw-r--r--target/linux/rb1xx-2.6/profiles/110-None.mk17
3 files changed, 51 insertions, 0 deletions
diff --git a/target/linux/rb1xx-2.6/profiles/100-Atheros.mk b/target/linux/rb1xx-2.6/profiles/100-Atheros.mk
new file mode 100644
index 0000000000..029586848f
--- /dev/null
+++ b/target/linux/rb1xx-2.6/profiles/100-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/rb1xx-2.6/profiles/105-Texas.mk b/target/linux/rb1xx-2.6/profiles/105-Texas.mk
new file mode 100644
index 0000000000..727a0c0648
--- /dev/null
+++ b/target/linux/rb1xx-2.6/profiles/105-Texas.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Texas
+ NAME:=Texas Instruments WiFi
+ PACKAGES:=kmod-acx
+endef
+
+define Profile/Texas/Description
+ Package set compatible with hardware using Texas Instruments WiFi cards
+endef
+$(eval $(call Profile,Texas))
+
diff --git a/target/linux/rb1xx-2.6/profiles/110-None.mk b/target/linux/rb1xx-2.6/profiles/110-None.mk
new file mode 100644
index 0000000000..2fcfacde9f
--- /dev/null
+++ b/target/linux/rb1xx-2.6/profiles/110-None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+