aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorZhenjian Zhang <itdesk.zhang@gmail.com>2019-08-13 14:30:29 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-08-24 08:55:33 +0800
commitfb3574f1238cd958554d0b77f157f15508247dae (patch)
tree0dde1b4cf4bc23f85845bbb0c972adea81ccca52 /target/linux/ramips
parent4346de8d34b541bb6b2eb7025119aeb150e4dab8 (diff)
downloadupstream-fb3574f1238cd958554d0b77f157f15508247dae.tar.gz
upstream-fb3574f1238cd958554d0b77f157f15508247dae.tar.bz2
upstream-fb3574f1238cd958554d0b77f157f15508247dae.zip
ramips: add support for ADSLR G7
SoC: MT7621AT RAM: 256MB Flash: 16M SPI Ethernet: 5x GE ports WiFi: 2.4G: MT7615N 5G: MT7615N Flash instruction: 1.Modify the file to linux.bin 2.Set up FTP service 3.Computer settings fixed IP: 192.168.179.50 255.255.255.0 4.Turn on the power and press and hold the reset button until the indicator light is on for about 5 seconds. Signed-off-by: Zhenjian Zhang <itdesk.zhang@gmail.com> [fix mac location] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/dts/mt7621_adslr_g7.dts118
-rw-r--r--target/linux/ramips/image/mt7621.mk9
3 files changed, 128 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index c0de9d4e50..27f85d7458 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -39,6 +39,7 @@ ramips_setup_interfaces()
upvel,ur-336un)
ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
;;
+ adslr,g7|\
afoundry,ew1200|\
aigale,ai-br100|\
alfa-network,ac1200rm|\
diff --git a/target/linux/ramips/dts/mt7621_adslr_g7.dts b/target/linux/ramips/dts/mt7621_adslr_g7.dts
new file mode 100644
index 0000000000..9c92d77102
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_adslr_g7.dts
@@ -0,0 +1,118 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "adslr,g7", "mediatek,mt7621-soc";
+ model = "ADSLR G7";
+
+ aliases {
+ led-boot = &led_sys;
+ led-failsafe = &led_sys;
+ led-running = &led_sys;
+ led-upgrade = &led_sys;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ led_sys: sys {
+ label = "g7:blue:sys";
+ gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 8 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <40000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&pcie0 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x0000>;
+ ieee80211-freq-limit = <2400000 2500000>;
+ };
+};
+
+&pcie1 {
+ wifi@0,0 {
+ compatible = "mediatek,mt76";
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0xe00c>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d32feb7eab..5dc8efe7c5 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -535,6 +535,15 @@ define Device/totolink_a7000r
endef
TARGET_DEVICES += totolink_a7000r
+define Device/adslr_g7
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := ADSLR
+ DEVICE_MODEL := G7
+ DEVICE_PACKAGES := kmod-mt7615e wpad-basic
+endef
+TARGET_DEVICES += adslr_g7
+
define Device/tplink-safeloader
MTK_SOC := mt7621
DEVICE_VENDOR := TP-Link