aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorFelix Baumann <felix.bau@gmx.de>2023-05-20 08:37:45 +0200
committerFelix Baumann <felix.bau@gmx.de>2023-05-21 01:08:22 +0200
commitf5cb556d4f70e7aac428857fe782b58ece0cf188 (patch)
tree5cb0a1675cfec759d97837e3e9fdad955879f21c /target/linux/ramips
parent3f297be1ed49351282f26462a7aa6e03036a1ffc (diff)
downloadupstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.gz
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.tar.bz2
upstream-f5cb556d4f70e7aac428857fe782b58ece0cf188.zip
treewide: Disable building 32M RAM devices
Following deprecation notice[1] in 21.02, disable targets with 32M of RAM [1] https://openwrt.org/supported_devices/864_warning Signed-off-by: Felix Baumann <felix.bau@gmx.de>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7620.mk5
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
-rw-r--r--target/linux/ramips/image/rt288x.mk1
-rw-r--r--target/linux/ramips/image/rt305x.mk48
-rw-r--r--target/linux/ramips/image/rt3883.mk1
5 files changed, 57 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 621162c970..7c2ff740f0 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -124,6 +124,7 @@ define Device/asus_rt-n12p
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-N11P/RT-N12+/RT-N12Eb1
SUPPORTED_DEVICES += rt-n12p
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n12p
@@ -191,6 +192,7 @@ define Device/comfast_cf-wr800n
DEVICE_VENDOR := Comfast
DEVICE_MODEL := CF-WR800N
SUPPORTED_DEVICES += cf-wr800n
+ DEFAULT := n
endef
TARGET_DEVICES += comfast_cf-wr800n
@@ -241,6 +243,7 @@ define Device/dlink_dwr-116-a1
DLINK_ROM_ID := DLK6E3803001
DLINK_FAMILY_MEMBER := 0x6E38
DLINK_FIRMWARE_SIZE := 0x7E0000
+ DEFAULT := n
endef
TARGET_DEVICES += dlink_dwr-116-a1
@@ -853,6 +856,7 @@ define Device/netgear_wn3000rp-v3
DEVICE_MODEL := WN3000RP
DEVICE_VARIANT := v3
SUPPORTED_DEVICES += wn3000rpv3
+ DEFAULT := n
endef
TARGET_DEVICES += netgear_wn3000rp-v3
@@ -1438,6 +1442,7 @@ define Device/zbtlink_zbt-wr8305rt
DEVICE_MODEL := ZBT-WR8305RT
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
SUPPORTED_DEVICES += zbt-wr8305rt
+ DEFAULT := n
endef
TARGET_DEVICES += zbtlink_zbt-wr8305rt
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 22db5c1382..816009ac18 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -68,6 +68,7 @@ define Device/asus_rt-n10p-v3
DEVICE_VENDOR := ASUS
DEVICE_MODEL := RT-N10P
DEVICE_VARIANT := V3
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n10p-v3
@@ -82,6 +83,7 @@ define Device/asus_rt-n11p-b1
DEVICE_ALT1_VENDOR := ASUS
DEVICE_ALT1_MODEL := RT-N300
DEVICE_ALT1_VARIANT := B1
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n11p-b1
diff --git a/target/linux/ramips/image/rt288x.mk b/target/linux/ramips/image/rt288x.mk
index c93d7d78e5..0fdb35d963 100644
--- a/target/linux/ramips/image/rt288x.mk
+++ b/target/linux/ramips/image/rt288x.mk
@@ -54,6 +54,7 @@ define Device/belkin_f5d8235-v1
DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-ohci kmod-usb-ohci-pci \
kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += f5d8235-v1
+ DEFAULT := n
endef
TARGET_DEVICES += belkin_f5d8235-v1
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 83658cffa2..815e03a8d4 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -43,6 +43,7 @@ define Device/7links_px-4885-8m
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb2 kmod-usb-ohci \
kmod-usb-ledtrig-usbport kmod-leds-gpio
SUPPORTED_DEVICES += px-4885-8M
+ DEFAULT := n
endef
TARGET_DEVICES += 7links_px-4885-8m
@@ -53,6 +54,7 @@ define Device/8devices_carambola
DEVICE_MODEL := Carambola
DEVICE_PACKAGES :=
SUPPORTED_DEVICES += carambola
+ DEFAULT := n
endef
TARGET_DEVICES += 8devices_carambola
@@ -62,6 +64,7 @@ define Device/accton_wr6202
DEVICE_VENDOR := Accton
DEVICE_MODEL := WR6202
SUPPORTED_DEVICES += wr6202
+ DEFAULT := n
endef
TARGET_DEVICES += accton_wr6202
@@ -81,6 +84,7 @@ define Device/alfa-network_w502u
DEVICE_VENDOR := ALFA
DEVICE_MODEL := Networks W502U
SUPPORTED_DEVICES += w502u
+ DEFAULT := n
endef
TARGET_DEVICES += alfa-network_w502u
@@ -104,6 +108,7 @@ define Device/allnet_all0256n-8m
DEVICE_VARIANT := 8M
DEVICE_PACKAGES := rssileds
SUPPORTED_DEVICES += all0256n-8M
+ DEFAULT := n
endef
TARGET_DEVICES += allnet_all0256n-8m
@@ -127,6 +132,7 @@ define Device/allnet_all5003
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
kmod-i2c-gpio kmod-hwmon-lm92 kmod-gpio-pcf857x
SUPPORTED_DEVICES += all5003
+ DEFAULT := n
endef
TARGET_DEVICES += allnet_all5003
@@ -138,6 +144,7 @@ define Device/alphanetworks_asl26555-16m
DEVICE_VARIANT := 16M
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += asl26555 asl26555-16M
+ DEFAULT := n
endef
TARGET_DEVICES += alphanetworks_asl26555-16m
@@ -148,6 +155,7 @@ define Device/alphanetworks_asl26555-8m
DEVICE_MODEL := ASL26555
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += asl26555 asl26555-8M
+ DEFAULT := n
endef
TARGET_DEVICES += alphanetworks_asl26555-8m
@@ -159,6 +167,7 @@ define Device/arcwireless_freestation5
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-rt2500-usb kmod-rt2800-usb \
kmod-rt2x00-usb
SUPPORTED_DEVICES += freestation5
+ DEFAULT := n
endef
TARGET_DEVICES += arcwireless_freestation5
@@ -201,6 +210,7 @@ define Device/asiarf_awm002-evb-8m
DEVICE_VARIANT := 8M
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-i2c-gpio
SUPPORTED_DEVICES += awm002-evb-8M
+ DEFAULT := n
endef
TARGET_DEVICES += asiarf_awm002-evb-8m
@@ -232,6 +242,7 @@ define Device/asus_rt-n13u
DEVICE_MODEL := RT-N13U
DEVICE_PACKAGES := kmod-leds-gpio kmod-rt2800-pci kmod-usb-dwc2
SUPPORTED_DEVICES += rt-n13u
+ DEFAULT := n
endef
TARGET_DEVICES += asus_rt-n13u
@@ -262,6 +273,7 @@ define Device/aximcom_mr-102n
DEVICE_VENDOR := AXIMCom
DEVICE_MODEL := MR-102N
SUPPORTED_DEVICES += mr-102n
+ DEFAULT := n
endef
TARGET_DEVICES += aximcom_mr-102n
@@ -274,6 +286,7 @@ define Device/aztech_hw550-3g
DEVICE_ALT0_MODEL := ALL0239-3G
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += hw550-3g
+ DEFAULT := n
endef
TARGET_DEVICES += aztech_hw550-3g
@@ -285,6 +298,7 @@ define Device/belkin_f5d8235-v2
DEVICE_VARIANT := v2
DEVICE_PACKAGES := kmod-switch-rtl8366rb
SUPPORTED_DEVICES += f5d8235-v2
+ DEFAULT := n
endef
TARGET_DEVICES += belkin_f5d8235-v2
@@ -294,6 +308,7 @@ define Device/belkin_f7c027
DEVICE_VENDOR := Belkin
DEVICE_MODEL := F7C027
SUPPORTED_DEVICES += f7c027
+ DEFAULT := n
endef
TARGET_DEVICES += belkin_f7c027
@@ -320,6 +335,7 @@ define Device/dlink_dap-1350
DEVICE_VENDOR := D-Link
DEVICE_MODEL := DAP-1350
SUPPORTED_DEVICES += dap-1350
+ DEFAULT := n
endef
TARGET_DEVICES += dlink_dap-1350
@@ -369,6 +385,7 @@ define Device/dlink_dir-300-b7
DEVICE_MODEL := DIR-300
DEVICE_VARIANT := B7
SUPPORTED_DEVICES += dir-300-b7
+ DEFAULT := n
endef
TARGET_DEVICES += dlink_dir-300-b7
@@ -379,6 +396,7 @@ define Device/dlink_dir-320-b1
DEVICE_MODEL := DIR-320
DEVICE_VARIANT := B1
SUPPORTED_DEVICES += dir-320-b1
+ DEFAULT := n
endef
TARGET_DEVICES += dlink_dir-320-b1
@@ -445,6 +463,7 @@ define Device/dlink_dir-620-a1
DEVICE_MODEL := DIR-620
DEVICE_VARIANT := A1
SUPPORTED_DEVICES += dir-620-a1
+ DEFAULT := n
endef
TARGET_DEVICES += dlink_dir-620-a1
@@ -455,6 +474,7 @@ define Device/dlink_dir-620-d1
DEVICE_MODEL := DIR-620
DEVICE_VARIANT := D1
SUPPORTED_DEVICES += dir-620-d1
+ DEFAULT := n
endef
TARGET_DEVICES += dlink_dir-620-d1
@@ -474,6 +494,7 @@ define Device/dlink_dwr-512-b
IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory
SUPPORTED_DEVICES += dwr-512-b
+ DEFAULT := n
endef
TARGET_DEVICES += dlink_dwr-512-b
@@ -484,6 +505,7 @@ define Device/easyacc_wizard-8800
DEVICE_VENDOR := EasyAcc
DEVICE_MODEL := WIZARD 8800
SUPPORTED_DEVICES += wizard8800
+ DEFAULT := n
endef
TARGET_DEVICES += easyacc_wizard-8800
@@ -558,6 +580,7 @@ define Device/hame_mpr-a2
DEVICE_VARIANT := A2
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
SUPPORTED_DEVICES += mpr-a2
+ DEFAULT := n
endef
TARGET_DEVICES += hame_mpr-a2
@@ -611,6 +634,7 @@ define Device/huawei_hg255d
DEVICE_VENDOR := HuaWei
DEVICE_MODEL := HG255D
SUPPORTED_DEVICES += hg255d
+ DEFAULT := n
endef
TARGET_DEVICES += huawei_hg255d
@@ -623,6 +647,7 @@ define Device/intenso_memory2move
DEVICE_PACKAGES := kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext4 \
kmod-fs-vfat block-mount
SUPPORTED_DEVICES += m2m
+ DEFAULT := n
endef
TARGET_DEVICES += intenso_memory2move
@@ -668,6 +693,7 @@ define Device/mofinetwork_mofi3500-3gn
DEVICE_VENDOR := MoFi Network
DEVICE_MODEL := MOFI3500-3GN
SUPPORTED_DEVICES += mofi3500-3gn
+ DEFAULT := n
endef
TARGET_DEVICES += mofinetwork_mofi3500-3gn
@@ -730,6 +756,7 @@ define Device/nexx_wt1520-8m
DEVICE_MODEL := WT1520
DEVICE_VARIANT := 8M
SUPPORTED_DEVICES += wt1520-8M
+ DEFAULT := n
endef
TARGET_DEVICES += nexx_wt1520-8m
@@ -741,6 +768,7 @@ define Device/nixcore_x1-16m
DEVICE_VARIANT := 16M
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-i2c-ralink kmod-spi-dev
SUPPORTED_DEVICES += nixcore-x1 nixcore-x1-16M
+ DEFAULT := n
endef
TARGET_DEVICES += nixcore_x1-16m
@@ -752,6 +780,7 @@ define Device/nixcore_x1-8m
DEVICE_VARIANT := 8M
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-i2c-ralink kmod-spi-dev
SUPPORTED_DEVICES += nixcore-x1 nixcore-x1-8M
+ DEFAULT := n
endef
TARGET_DEVICES += nixcore_x1-8m
@@ -763,6 +792,7 @@ define Device/olimex_rt5350f-olinuxino
DEVICE_MODEL := RT5350F-OLinuXino
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-i2c-ralink kmod-spi-dev
SUPPORTED_DEVICES += rt5350f-olinuxino
+ DEFAULT := n
endef
TARGET_DEVICES += olimex_rt5350f-olinuxino
@@ -774,6 +804,7 @@ define Device/olimex_rt5350f-olinuxino-evb
DEVICE_MODEL := RT5350F-OLinuXino-EVB
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-i2c-ralink kmod-spi-dev
SUPPORTED_DEVICES += rt5350f-olinuxino-evb
+ DEFAULT := n
endef
TARGET_DEVICES += olimex_rt5350f-olinuxino-evb
@@ -792,6 +823,7 @@ define Device/omnima_miniembwifi
DEVICE_VENDOR := Omnima
DEVICE_MODEL := MiniEMBWiFi
SUPPORTED_DEVICES += miniembwifi
+ DEFAULT := n
endef
TARGET_DEVICES += omnima_miniembwifi
@@ -835,6 +867,7 @@ define Device/planex_mzk-wdpr
DEVICE_VENDOR := Planex
DEVICE_MODEL := MZK-WDPR
SUPPORTED_DEVICES += mzk-wdpr
+ DEFAULT := n
endef
TARGET_DEVICES += planex_mzk-wdpr
@@ -887,6 +920,7 @@ define Device/poray_m4-8m
DEVICE_VARIANT := 8M
DEVICE_PACKAGES := kmod-usb2
SUPPORTED_DEVICES += m4-8M
+ DEFAULT := n
endef
TARGET_DEVICES += poray_m4-8m
@@ -900,6 +934,7 @@ define Device/poray_x5
DEVICE_MODEL := X5/X6
DEVICE_PACKAGES := kmod-usb2
SUPPORTED_DEVICES += x5
+ DEFAULT := n
endef
TARGET_DEVICES += poray_x5
@@ -913,6 +948,7 @@ define Device/poray_x8
DEVICE_MODEL := X8
DEVICE_PACKAGES := kmod-usb2
SUPPORTED_DEVICES += x8
+ DEFAULT := n
endef
TARGET_DEVICES += poray_x8
@@ -923,6 +959,7 @@ define Device/prolink_pwh2004
DEVICE_MODEL := PWH2004
DEVICE_PACKAGES :=
SUPPORTED_DEVICES += pwh2004
+ DEFAULT := n
endef
TARGET_DEVICES += prolink_pwh2004
@@ -973,6 +1010,7 @@ define Device/teltonika_rut5xx
DEVICE_VENDOR := Teltonika
DEVICE_MODEL := RUT5XX
SUPPORTED_DEVICES += rut5xx
+ DEFAULT := n
endef
TARGET_DEVICES += teltonika_rut5xx
@@ -1042,6 +1080,7 @@ define Device/trendnet_tew-714tru
DEVICE_VENDOR := TRENDnet
DEVICE_MODEL := TEW-714TRU
SUPPORTED_DEVICES += tew-714tru
+ DEFAULT := n
endef
TARGET_DEVICES += trendnet_tew-714tru
@@ -1077,6 +1116,7 @@ define Device/unbranded_wr512-3gn-8m
DEVICE_MODEL := WR512-3GN
DEVICE_VARIANT := 8M
SUPPORTED_DEVICES += wr512-3gn-8M
+ DEFAULT := n
endef
TARGET_DEVICES += unbranded_wr512-3gn-8m
@@ -1108,6 +1148,7 @@ define Device/upvel_ur-336un
DEVICE_MODEL := UR-336UN
DEVICE_PACKAGES := kmod-usb-dwc2 kmod-usb-ledtrig-usbport
SUPPORTED_DEVICES += ur-336un
+ DEFAULT := n
endef
TARGET_DEVICES += upvel_ur-336un
@@ -1119,6 +1160,7 @@ define Device/vocore_vocore-16m
DEVICE_VARIANT := 16M
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-i2c-ralink kmod-spi-dev
SUPPORTED_DEVICES += vocore vocore-16M
+ DEFAULT := n
endef
TARGET_DEVICES += vocore_vocore-16m
@@ -1130,6 +1172,7 @@ define Device/vocore_vocore-8m
DEVICE_VARIANT := 8M
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-i2c-ralink kmod-spi-dev
SUPPORTED_DEVICES += vocore vocore-8M
+ DEFAULT := n
endef
TARGET_DEVICES += vocore_vocore-8m
@@ -1149,6 +1192,7 @@ define Device/wiznet_wizfi630a
DEVICE_VENDOR := WIZnet
DEVICE_MODEL := WizFi630A
SUPPORTED_DEVICES += wizfi630a
+ DEFAULT := n
endef
TARGET_DEVICES += wiznet_wizfi630a
@@ -1158,6 +1202,7 @@ define Device/zorlik_zl5900v2
DEVICE_VENDOR := Zorlik
DEVICE_MODEL := ZL5900V2
DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
+ DEFAULT := n
endef
TARGET_DEVICES += zorlik_zl5900v2
@@ -1180,6 +1225,7 @@ define Device/zyxel_keenetic
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ehci kmod-usb-ledtrig-usbport \
kmod-usb-dwc2
SUPPORTED_DEVICES += kn
+ DEFAULT := n
endef
TARGET_DEVICES += zyxel_keenetic
@@ -1190,6 +1236,7 @@ define Device/zyxel_keenetic-4g-b
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := Keenetic 4G
DEVICE_VARIANT := B
+ DEFAULT := n
endef
TARGET_DEVICES += zyxel_keenetic-4g-b
@@ -1200,6 +1247,7 @@ define Device/zyxel_keenetic-lite-b
DEVICE_VENDOR := ZyXEL
DEVICE_MODEL := Keenetic Lite
DEVICE_VARIANT := B
+ DEFAULT := n
endef
TARGET_DEVICES += zyxel_keenetic-lite-b
diff --git a/target/linux/ramips/image/rt3883.mk b/target/linux/ramips/image/rt3883.mk
index 0d12aa0a40..0430099296 100644
--- a/target/linux/ramips/image/rt3883.mk
+++ b/target/linux/ramips/image/rt3883.mk
@@ -72,6 +72,7 @@ define Device/loewe_wmdr-143n
DEVICE_VENDOR := Loewe
DEVICE_MODEL := WMDR-143N
SUPPORTED_DEVICES += wmdr-143n
+ DEFAULT := n
endef
TARGET_DEVICES += loewe_wmdr-143n