aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2021-06-09 12:22:39 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-06-09 22:18:37 +0200
commite1d8a14cd0a9f8844f9ebb8ca220780b0ce5d6db (patch)
tree4d16d993f524e04ec14357eeca37d948927ac5b9 /target/linux/ramips
parentae9c5cd37bf5c08452f314b54afa963a00bdde30 (diff)
downloadupstream-e1d8a14cd0a9f8844f9ebb8ca220780b0ce5d6db.tar.gz
upstream-e1d8a14cd0a9f8844f9ebb8ca220780b0ce5d6db.tar.bz2
upstream-e1d8a14cd0a9f8844f9ebb8ca220780b0ce5d6db.zip
ramips: mt7620: add kernel size for Jboot devices
Since few months multiple users reported problems with various JBoot devices. [0][1][2][3] All of them was bricked. On my Lava LR-25G001 it freezes with current snapshot: CDW57CAM_003 Jboot B695 Giga Switch AR8327 init AR8327/AR8337 id ==> 0x1302 JRecovery Version R1.2 2014/04/01 18:25 SPI FLASH: MX25l12805d 16M . . (freeze) The kernel size is >2048k. I built current master with minimal config and it boots well: CDW57CAM_003 Jboot B695 Giga Switch AR8327 init AR8327/AR8337 id ==> 0x1302 JRecovery Version R1.2 2014/04/01 18:25 SPI FLASH: MX25l12805d 16M . ........................... Starting kernel @80000000... [ 0.000000] Linux version 5.4.124 Kernel size is <2048k. Jboot bootloader isn't open source, so it's impossible to find solution in code. It looks, that some buffer for kernel have 2MB size. To avoid bricked devices, this commit introduces 2048k limit kernel size for all jboot routers. [0] https://bugs.openwrt.org/index.php?do=details&task_id=3539 [1] https://eko.one.pl/forum/viewtopic.php?pid=254344 [2] https://eko.one.pl/forum/viewtopic.php?id=20930 [3] https://eko.one.pl/forum/viewtopic.php?pid=241376#p241376 Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> [remove Fixes:] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7620.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 8f5d354e33..e56e96d347 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -62,6 +62,7 @@ TARGET_DEVICES += alfa-network_tube-e4g
define Device/amit_jboot
DLINK_IMAGE_OFFSET := 0x10000
KERNEL := $(KERNEL_DTB)
+ KERNEL_SIZE := 2048k
IMAGES += factory.bin
IMAGE/sysupgrade.bin := mkdlinkfw | pad-rootfs | append-metadata
IMAGE/factory.bin := mkdlinkfw | pad-rootfs | mkdlinkfw-factory