aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorChuanhong Guo <gch981213@gmail.com>2020-04-14 11:17:47 +0800
committerChuanhong Guo <gch981213@gmail.com>2020-04-14 11:17:47 +0800
commitd9e9a0e6b11aa461aef1a030e5782292afb58338 (patch)
tree9dc3b1173f351f80a879a31d8d01d58d957df0dd /target/linux/ramips
parent111029bea7b5c1075f7aa12e8431fe840c3dca12 (diff)
downloadupstream-d9e9a0e6b11aa461aef1a030e5782292afb58338.tar.gz
upstream-d9e9a0e6b11aa461aef1a030e5782292afb58338.tar.bz2
upstream-d9e9a0e6b11aa461aef1a030e5782292afb58338.zip
ramips: define lzma loader platform in target
Loader platform is a per-soc variable instead of a per-device one. Determine corresponding loader platform at the beginning of image Makefile. Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/Makefile6
-rw-r--r--target/linux/ramips/image/mt7621.mk1
2 files changed, 5 insertions, 2 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 29db341e9b..bc5de7d8d0 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -18,7 +18,11 @@ loadaddr-y := 0x80000000
loadaddr-$(CONFIG_TARGET_ramips_rt288x) := 0x88000000
loadaddr-$(CONFIG_TARGET_ramips_mt7621) := 0x80001000
+ldrplatform-y := ralink
+ldrplatform-$(CONFIG_TARGET_ramips_mt7621) := mt7621
+
KERNEL_LOADADDR := $(loadaddr-y)
+LOADER_PLATFORM := $(ldrplatform-y)
KERNEL_DTB = kernel-bin | append-dtb | lzma
define Device/Default
@@ -68,7 +72,7 @@ define Build/loader-common
$(MAKE) -C lzma-loader \
PKG_BUILD_DIR="$@.src" \
TARGET_DIR="$(dir $@)" LOADER_NAME="$(notdir $@)" \
- BOARD="$(BOARDNAME)" PLATFORM="$(PLATFORM)" \
+ BOARD="$(BOARDNAME)" PLATFORM="$(LOADER_PLATFORM)" \
LZMA_TEXT_START=0x82000000 LOADADDR=$(KERNEL_LOADADDR) \
$(1) compile loader.$(LOADER_TYPE)
mv "$@.$(LOADER_TYPE)" "$@"
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 806286b0bb..8980ff70d4 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -504,7 +504,6 @@ define Device/MikroTik
IMAGE_SIZE := 16128k
DEVICE_PACKAGES := kmod-usb3
LOADER_TYPE := elf
- PLATFORM := mt7621
KERNEL := $(KERNEL_DTB) | loader-kernel
IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | \
pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | append-metadata | \