aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorThibaut VARÈNE <hacks@slashdirt.org>2018-07-19 18:06:21 +0200
committerMathias Kresin <dev@kresin.me>2018-07-19 18:58:24 +0200
commitc4f09fc9f8e97b11519e52d2f1e6a7bc02e4d2be (patch)
treec7e088446672cb8a6ec83514efffeeb955072121 /target/linux/ramips
parent02d53e6a2113f80ae429664e7990d167fbf44604 (diff)
downloadupstream-c4f09fc9f8e97b11519e52d2f1e6a7bc02e4d2be.tar.gz
upstream-c4f09fc9f8e97b11519e52d2f1e6a7bc02e4d2be.tar.bz2
upstream-c4f09fc9f8e97b11519e52d2f1e6a7bc02e4d2be.zip
ramips: define common MikroTik RouterBOARD image recipe
All these devices share the exact same image format. The usb3 kmod is added for the rbm11g, as the rbm11g has a mini-pcie slot like its bigger sibling. The usb kmod is necessary for usb-over-pcie support, which is mandatory for a lot of LTE modules. Signed-off-by: Thibaut VARÈNE <hacks@slashdirt.org>
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/image/mt7621.mk20
1 files changed, 9 insertions, 11 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index fa87e40520..8ac78ad7de 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -260,11 +260,9 @@ define Device/rb750gr3
endef
TARGET_DEVICES += rb750gr3
-define Device/mikrotik_rbm33g
- DTS := RBM33G
+define Device/MikroTik
BLOCKSIZE := 64k
IMAGE_SIZE := 16128k
- DEVICE_TITLE := MikroTik RBM33G
DEVICE_PACKAGES := kmod-usb3
LOADER_TYPE := elf
PLATFORM := mt7621
@@ -272,18 +270,18 @@ define Device/mikrotik_rbm33g
IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | pad-to $$$$(BLOCKSIZE) | \
append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
+
+define Device/mikrotik_rbm33g
+ $(Device/MikroTik)
+ DTS := RBM33G
+ DEVICE_TITLE := MikroTik RouterBOARD M33G
+endef
TARGET_DEVICES += mikrotik_rbm33g
define Device/mikrotik_rbm11g
+ $(Device/MikroTik)
DTS := RBM11G
- BLOCKSIZE := 64k
- IMAGE_SIZE := 16128k
- DEVICE_TITLE := MikroTik RBM11G
- LOADER_TYPE := elf
- PLATFORM := mt7621
- KERNEL := kernel-bin | patch-dtb | lzma | loader-kernel
- IMAGE/sysupgrade.bin := append-kernel | kernel2minor -s 1024 | pad-to $$$$(BLOCKSIZE) | \
- append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+ DEVICE_TITLE := MikroTik RouterBOARD M11G
endef
TARGET_DEVICES += mikrotik_rbm11g