aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorQi Jiang <rushx@live.cn>2019-09-08 09:52:07 +0800
committerChuanhong Guo <gch981213@gmail.com>2019-09-25 14:44:36 +0800
commit93b6cc97ca9694434faef69c6c5145b5dc7c1ae4 (patch)
tree473e82ddc6137c2738619536d48d2de6e9befa0c /target/linux/ramips
parente39d1cf34f97667b8fc1cdb60beec7a12e70839d (diff)
downloadupstream-93b6cc97ca9694434faef69c6c5145b5dc7c1ae4.tar.gz
upstream-93b6cc97ca9694434faef69c6c5145b5dc7c1ae4.tar.bz2
upstream-93b6cc97ca9694434faef69c6c5145b5dc7c1ae4.zip
ramips: add support for XiaoYu XY-C5
Hardware: SoC: MT7621A Flash: 32 MiB RAM: 512 MiB Ethernet: built-in switch USB: 1x USB3.0 SATA: ASM1060, 1 SATA port Flash instruction (TFTP): 1. Set PC to fixed ip address 192.168.173.22 2. Download *-sysupgrade.bin image and rename it to firmware.img 3. Start a tftp server with the image file in its root directory 4. Turn off the router 5. Turn on router,press the reset button and wait ~15 seconds 6. Release the reset button and after a short time the firmware should be transferred from the tftp server 7. Wait ~3 minutes to complete recovery. Signed-off-by: Qi Jiang <rushx@live.cn> [squash commits, add label-mac-device, fix sign-off style] Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/dts/mt7621_xiaoyu_xy-c5.dts104
-rw-r--r--target/linux/ramips/image/mt7621.mk9
3 files changed, 114 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 63644331e5..8af534dbc2 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -88,6 +88,7 @@ ramips_setup_interfaces()
wavlink,wl-wn575a3|\
xiaomi,miwifi-mini|\
xiaomi,miwifi-nano|\
+ xiaoyu,xy-c5|\
xzwifi,creativebox-v1|\
youku,yk-l2|\
youku,yk1|\
diff --git a/target/linux/ramips/dts/mt7621_xiaoyu_xy-c5.dts b/target/linux/ramips/dts/mt7621_xiaoyu_xy-c5.dts
new file mode 100644
index 0000000000..072b2cc455
--- /dev/null
+++ b/target/linux/ramips/dts/mt7621_xiaoyu_xy-c5.dts
@@ -0,0 +1,104 @@
+/dts-v1/;
+
+#include "mt7621.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "xiaoyu,xy-c5", "mediatek,mt7621-soc";
+ model = "XiaoYu XY-C5";
+
+ aliases {
+ led-boot = &led_sys;
+ led-failsafe = &led_sys;
+ led-running = &led_sys;
+ led-upgrade = &led_sys;
+ label-mac-device = &ethernet;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,57600";
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ work {
+ label = "xy-c5:green:work";
+ gpios = <&gpio0 8 GPIO_ACTIVE_LOW>;
+ };
+
+ led_sys: sys {
+ label = "xy-c5:green:sys";
+ gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ gpios = <&gpio0 18 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0x1fb0000>;
+ };
+ };
+ };
+};
+
+&pcie {
+ status = "okay";
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x4>;
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "uart3", "wdt";
+ ralink,function = "gpio";
+ };
+ };
+};
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f098976dfc..644f984197 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -768,6 +768,15 @@ define Device/xiaomi_mir3p
endef
TARGET_DEVICES += xiaomi_mir3p
+define Device/xiaoyu_xy-c5
+ MTK_SOC := mt7621
+ IMAGE_SIZE := 32448k
+ DEVICE_VENDOR := XiaoYu
+ DEVICE_MODEL := XY-C5
+ DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-usb3
+endef
+TARGET_DEVICES += xiaoyu_xy-c5
+
define Device/xzwifi_creativebox-v1
MTK_SOC := mt7621
IMAGE_SIZE := 32448k