aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-07-28 19:22:55 +0200
committerMathias Kresin <dev@kresin.me>2017-07-29 09:24:59 +0200
commit5e409f0e69ce77186f4e70dd9068e43dfc36a9bc (patch)
tree8eb7a5562fc22fe6c1734184b705bf2ccd965b61 /target/linux/ramips
parent5e87b01275e20226a08538d447ca7714e824cc2c (diff)
downloadupstream-5e409f0e69ce77186f4e70dd9068e43dfc36a9bc.tar.gz
upstream-5e409f0e69ce77186f4e70dd9068e43dfc36a9bc.tar.bz2
upstream-5e409f0e69ce77186f4e70dd9068e43dfc36a9bc.zip
ramips: fix Mercury MAC1200R v2.0 board name
With d2b6bf141662 ("ramips: fix image validation errors") the board name was changed to fix an image validation error. But this change wasn't applied to all other files using the board name, which broke sysupgrade. Revert this change and use the former board name in the metadata instead. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh2
-rw-r--r--target/linux/ramips/image/mt7628.mk1
2 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index e642d568c4..17ada64893 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -272,7 +272,7 @@ ramips_board_detect() {
name="m2m"
;;
*"Mercury MAC1200R v2")
- name="mac1200r-v2"
+ name="mac1200rv2"
;;
*"MicroWRT")
name="microwrt"
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
index 4502588c80..12c3c80507 100644
--- a/target/linux/ramips/image/mt7628.mk
+++ b/target/linux/ramips/image/mt7628.mk
@@ -53,5 +53,6 @@ TARGET_DEVICES += duzun-dm06
define Device/mac1200r-v2
DTS := MAC1200RV2
DEVICE_TITLE := Mercury MAC1200R v2.0
+ SUPPORTED_DEVICES := mac1200rv2
endef
TARGET_DEVICES += mac1200r-v2