aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-11-28 00:31:10 +0100
committerMathias Kresin <dev@kresin.me>2018-11-28 00:50:35 +0100
commit509d02a3d185e5fb240496471455f8999f8bd767 (patch)
tree27dc393b9ba18b79a736d4ce5886202cfb32b7d7 /target/linux/ramips
parenta160f50d4f240019fafe95e80701ebb871c788fe (diff)
downloadupstream-509d02a3d185e5fb240496471455f8999f8bd767.tar.gz
upstream-509d02a3d185e5fb240496471455f8999f8bd767.tar.bz2
upstream-509d02a3d185e5fb240496471455f8999f8bd767.zip
ramips: use generic board detection for Unielec u7621-06
Use the generic board detection for the board instead of the target specific one. Mark the sysupgrade image compatible with the former used userspace boardname to allow an upgrade from earlier versions. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network2
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh2
-rw-r--r--target/linux/ramips/image/mt7621.mk17
4 files changed, 11 insertions, 13 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index cdba37d38f..bb7069a77a 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -115,7 +115,7 @@ ramips_setup_interfaces()
rt-n12p|\
sap-g3200u3|\
sk-wb8|\
- u7621-06-256M-16M|\
+ unielec,u7621-06-256m-16m|\
vr500|\
wavlink,wl-wn570ha1|\
wf-2881|\
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 5741cbd2ee..307ab35c3c 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -502,9 +502,6 @@ ramips_board_detect() {
*"U25AWF-H1")
name="u25awf-h1"
;;
- *"U7621-06 (256M RAM/16M flash)")
- name="u7621-06-256M-16M"
- ;;
*"U7628-01 (128M RAM/16M flash)")
name="u7628-01-128M-16M"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index fc73f37e29..8c72019297 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -162,7 +162,7 @@ platform_check_image() {
timecloud|\
tiny-ac|\
u25awf-h1|\
- u7621-06-256M-16M|\
+ unielec,u7621-06-256m-16m|\
u7628-01-128M-16M|\
ur-326n4g|\
ur-336un|\
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e0c2f55ad1..e6059e6977 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -366,14 +366,6 @@ define Device/timecloud
endef
TARGET_DEVICES += timecloud
-define Device/u7621-06-256M-16M
- DTS := U7621-06-256M-16M
- IMAGE_SIZE := 16064k
- DEVICE_TITLE := UniElec U7621-06 (256M RAM/16M flash)
- DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
-endef
-TARGET_DEVICES += u7621-06-256M-16M
-
define Device/ubnt-erx
DTS := UBNT-ERX
FILESYSTEMS := squashfs
@@ -394,6 +386,15 @@ define Device/ubnt-erx-sfp
endef
TARGET_DEVICES += ubnt-erx-sfp
+define Device/unielec_u7621-06-256m-16m
+ DTS := U7621-06-256M-16M
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := UniElec U7621-06 (256M RAM/16M flash)
+ DEVICE_PACKAGES := kmod-ata-core kmod-ata-ahci kmod-sdhci-mt7620 kmod-usb3
+ SUPPORTED_DEVICES += u7621-06-256M-16M
+endef
+TARGET_DEVICES += unielec_u7621-06-256m-16m
+
define Device/vr500
DTS := VR500
IMAGE_SIZE := 66453504