aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorEdmunt Pienkowsky <roed@onet.eu>2017-10-21 11:07:43 +0200
committerMathias Kresin <dev@kresin.me>2017-10-27 11:19:07 +0200
commit3eae19acee79d40ecb151a23f1f79110995f9386 (patch)
treea04bcfd9dfac5ead9dbb57448bd3b9b5b6422dea /target/linux/ramips
parent8a48a53dcb503137a8eac64cf3fc522024484818 (diff)
downloadupstream-3eae19acee79d40ecb151a23f1f79110995f9386.tar.gz
upstream-3eae19acee79d40ecb151a23f1f79110995f9386.tar.bz2
upstream-3eae19acee79d40ecb151a23f1f79110995f9386.zip
ramips: fix Youku-YK1 support
Remove the ephy-pins from the ethernet device tree node. The ephy-pins are useed to controll the ePHY LEDs and this board doesn't have these. Instead one of the ePHY pins is used in GPIO mode to control the WAN LED. Use the switch LED trigger to control the WAN LED. Move the power LED handling to diag.sh to show the boot status via this LED. Add the missing kernel packages for USB and microSD card reader to the default package selection. Fix the maximum image size value. The board has a 32MByte flash chip. Fixes: FS#1055 Signed-off-by: Edmunt Pienkowsky <roed@onet.eu> [make the commit message more verbose, remove GPIO pinmux for pins not used as GPIOs] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds2
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rw-r--r--target/linux/ramips/dts/YOUKU-YK1.dts3
-rw-r--r--target/linux/ramips/image/mt7620.mk3
4 files changed, 6 insertions, 5 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 2956defca8..e8c29fa037 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -387,9 +387,9 @@ zte-q7)
set_wifi_led "$board:blue:status"
;;
youku-yk1)
- ucidef_set_led_default "power" "power" "$board:blue:power" "1"
set_wifi_led "$board:blue:air"
set_usb_led "$board:blue:usb"
+ ucidef_set_led_switch "wan" "wan" "$board:blue:wan" "switch0" "0x10"
;;
esac
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index cf3d2ca9c9..fa0391ca9b 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -122,7 +122,8 @@ get_status_led() {
wli-tx4-ag300n|\
wt3020|\
y1|\
- y1s)
+ y1s|\
+ youku-yk1)
status_led="$board:blue:power"
;;
db-wrt01|\
diff --git a/target/linux/ramips/dts/YOUKU-YK1.dts b/target/linux/ramips/dts/YOUKU-YK1.dts
index 260f86ab96..8c87981edf 100644
--- a/target/linux/ramips/dts/YOUKU-YK1.dts
+++ b/target/linux/ramips/dts/YOUKU-YK1.dts
@@ -95,7 +95,7 @@
&pinctrl {
state_default: pinctrl0 {
default {
- ralink,group = "i2c", "uartf", "rgmii1", "rgmii2", "ephy", "wled", "nd_sd";
+ ralink,group = "i2c", "rgmii1", "ephy", "wled";
ralink,function = "gpio";
};
};
@@ -103,7 +103,6 @@
&ethernet {
pinctrl-names = "default";
- pinctrl-0 = <&ephy_pins>;
mtd-mac-address = <&factory 0x4>;
mediatek,portmap = "llllw";
};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index ccf8d521f5..1736d9f480 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -382,8 +382,9 @@ TARGET_DEVICES += zte-q7
define Device/youku-yk1
DTS := YOUKU-YK1
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := $(ralink_default_fw_size_32M)
DEVICE_TITLE := YOUKU YK1
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
endef
TARGET_DEVICES += youku-yk1