aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2013-09-25 17:13:24 +0000
committerGabor Juhos <juhosg@openwrt.org>2013-09-25 17:13:24 +0000
commit0380904acb3a31738cb764407a7770bd91ff3e2b (patch)
treea08dd32b99c3bdea8647dfe79618571c82b65be7 /target/linux/ramips
parent76a16170630c05175215b1e5909ad8bdc417e336 (diff)
downloadupstream-0380904acb3a31738cb764407a7770bd91ff3e2b.tar.gz
upstream-0380904acb3a31738cb764407a7770bd91ff3e2b.tar.bz2
upstream-0380904acb3a31738cb764407a7770bd91ff3e2b.zip
kernel/3.10: refresh all target patches
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 38182
Diffstat (limited to 'target/linux/ramips')
-rw-r--r--target/linux/ramips/patches-3.10/0004-watchdog-MIPS-add-ralink-watchdog-driver.patch4
-rw-r--r--target/linux/ramips/patches-3.10/0006-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch36
-rw-r--r--target/linux/ramips/patches-3.10/0122-pinmux.patch92
-rw-r--r--target/linux/ramips/patches-3.10/0202-owrt-USB-adds-dwc_otg.patch8
-rw-r--r--target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch2
-rw-r--r--target/linux/ramips/patches-3.10/0205-uvc-add-iPassion-iP2970-support.patch36
6 files changed, 68 insertions, 110 deletions
diff --git a/target/linux/ramips/patches-3.10/0004-watchdog-MIPS-add-ralink-watchdog-driver.patch b/target/linux/ramips/patches-3.10/0004-watchdog-MIPS-add-ralink-watchdog-driver.patch
index 8f67315098..4b44d86dc2 100644
--- a/target/linux/ramips/patches-3.10/0004-watchdog-MIPS-add-ralink-watchdog-driver.patch
+++ b/target/linux/ramips/patches-3.10/0004-watchdog-MIPS-add-ralink-watchdog-driver.patch
@@ -17,7 +17,7 @@ Cc: linux-mips@linux-mips.org
--- a/drivers/watchdog/Kconfig
+++ b/drivers/watchdog/Kconfig
-@@ -1104,6 +1104,13 @@ config LANTIQ_WDT
+@@ -1113,6 +1113,13 @@ config LANTIQ_WDT
help
Hardware driver for the Lantiq SoC Watchdog Timer.
@@ -33,7 +33,7 @@ Cc: linux-mips@linux-mips.org
# POWERPC Architecture
--- a/drivers/watchdog/Makefile
+++ b/drivers/watchdog/Makefile
-@@ -134,6 +134,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+@@ -135,6 +135,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
diff --git a/target/linux/ramips/patches-3.10/0006-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch b/target/linux/ramips/patches-3.10/0006-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch
index 19d592bde2..989d2f36d4 100644
--- a/target/linux/ramips/patches-3.10/0006-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch
+++ b/target/linux/ramips/patches-3.10/0006-GPIO-MIPS-ralink-add-gpio-driver-for-ralink-SoC.patch
@@ -19,11 +19,9 @@ Cc: linux-gpio@vger.kernel.org
create mode 100644 arch/mips/include/asm/mach-ralink/gpio.h
create mode 100644 drivers/gpio/gpio-ralink.c
-Index: linux-3.10.9/arch/mips/Kconfig
-===================================================================
---- linux-3.10.9.orig/arch/mips/Kconfig 2013-08-26 17:48:27.481164281 +0200
-+++ linux-3.10.9/arch/mips/Kconfig 2013-08-27 23:15:40.751965869 +0200
-@@ -444,6 +444,7 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -444,6 +444,7 @@ config RALINK
select SYS_HAS_EARLY_PRINTK
select HAVE_MACH_CLKDEV
select CLKDEV_LOOKUP
@@ -31,10 +29,8 @@ Index: linux-3.10.9/arch/mips/Kconfig
config SGI_IP22
bool "SGI IP22 (Indy/Indigo2)"
-Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/gpio.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.9/arch/mips/include/asm/mach-ralink/gpio.h 2013-08-26 17:48:30.941164428 +0200
+--- /dev/null
++++ b/arch/mips/include/asm/mach-ralink/gpio.h
@@ -0,0 +1,24 @@
+/*
+ * Ralink SoC GPIO API support
@@ -60,11 +56,9 @@ Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/gpio.h
+#define gpio_to_irq __gpio_to_irq
+
+#endif /* __ASM_MACH_RALINK_GPIO_H */
-Index: linux-3.10.9/drivers/gpio/Kconfig
-===================================================================
---- linux-3.10.9.orig/drivers/gpio/Kconfig 2013-08-21 00:40:47.000000000 +0200
-+++ linux-3.10.9/drivers/gpio/Kconfig 2013-08-26 17:48:30.941164428 +0200
-@@ -209,6 +209,12 @@
+--- a/drivers/gpio/Kconfig
++++ b/drivers/gpio/Kconfig
+@@ -209,6 +209,12 @@ config GPIO_RCAR
help
Say yes here to support GPIO on Renesas R-Car SoCs.
@@ -77,11 +71,9 @@ Index: linux-3.10.9/drivers/gpio/Kconfig
config GPIO_SPEAR_SPICS
bool "ST SPEAr13xx SPI Chip Select as GPIO support"
depends on PLAT_SPEAR
-Index: linux-3.10.9/drivers/gpio/Makefile
-===================================================================
---- linux-3.10.9.orig/drivers/gpio/Makefile 2013-08-21 00:40:47.000000000 +0200
-+++ linux-3.10.9/drivers/gpio/Makefile 2013-08-26 17:48:30.941164428 +0200
-@@ -56,6 +56,7 @@
+--- a/drivers/gpio/Makefile
++++ b/drivers/gpio/Makefile
+@@ -56,6 +56,7 @@ obj-$(CONFIG_GPIO_PCF857X) += gpio-pcf85
obj-$(CONFIG_GPIO_PCH) += gpio-pch.o
obj-$(CONFIG_GPIO_PL061) += gpio-pl061.o
obj-$(CONFIG_GPIO_PXA) += gpio-pxa.o
@@ -89,10 +81,8 @@ Index: linux-3.10.9/drivers/gpio/Makefile
obj-$(CONFIG_GPIO_RC5T583) += gpio-rc5t583.o
obj-$(CONFIG_GPIO_RDC321X) += gpio-rdc321x.o
obj-$(CONFIG_GPIO_RCAR) += gpio-rcar.o
-Index: linux-3.10.9/drivers/gpio/gpio-ralink.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.9/drivers/gpio/gpio-ralink.c 2013-08-27 22:37:34.999868257 +0200
+--- /dev/null
++++ b/drivers/gpio/gpio-ralink.c
@@ -0,0 +1,345 @@
+/*
+ * This program is free software; you can redistribute it and/or modify it
diff --git a/target/linux/ramips/patches-3.10/0122-pinmux.patch b/target/linux/ramips/patches-3.10/0122-pinmux.patch
index fa0dd05226..f31e47689f 100644
--- a/target/linux/ramips/patches-3.10/0122-pinmux.patch
+++ b/target/linux/ramips/patches-3.10/0122-pinmux.patch
@@ -14,11 +14,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
6 files changed, 385 insertions(+), 19 deletions(-)
create mode 100644 drivers/pinctrl/pinctrl-rt2880.c
-Index: linux-3.10.9/arch/mips/Kconfig
-===================================================================
---- linux-3.10.9.orig/arch/mips/Kconfig 2013-08-28 16:34:42.449951676 +0200
-+++ linux-3.10.9/arch/mips/Kconfig 2013-08-28 16:34:43.361951711 +0200
-@@ -446,6 +446,8 @@
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -446,6 +446,8 @@ config RALINK
select HAVE_MACH_CLKDEV
select CLKDEV_LOOKUP
select ARCH_REQUIRE_GPIOLIB
@@ -27,11 +25,9 @@ Index: linux-3.10.9/arch/mips/Kconfig
config SGI_IP22
bool "SGI IP22 (Indy/Indigo2)"
-Index: linux-3.10.9/drivers/pinctrl/Kconfig
-===================================================================
---- linux-3.10.9.orig/drivers/pinctrl/Kconfig 2013-08-21 00:40:47.000000000 +0200
-+++ linux-3.10.9/drivers/pinctrl/Kconfig 2013-08-28 16:34:43.361951711 +0200
-@@ -114,6 +114,11 @@
+--- a/drivers/pinctrl/Kconfig
++++ b/drivers/pinctrl/Kconfig
+@@ -114,6 +114,11 @@ config PINCTRL_LANTIQ
select PINMUX
select PINCONF
@@ -43,11 +39,9 @@ Index: linux-3.10.9/drivers/pinctrl/Kconfig
config PINCTRL_FALCON
bool
depends on SOC_FALCON
-Index: linux-3.10.9/drivers/pinctrl/Makefile
-===================================================================
---- linux-3.10.9.orig/drivers/pinctrl/Makefile 2013-08-21 00:40:47.000000000 +0200
-+++ linux-3.10.9/drivers/pinctrl/Makefile 2013-08-28 16:34:43.361951711 +0200
-@@ -45,6 +45,7 @@
+--- a/drivers/pinctrl/Makefile
++++ b/drivers/pinctrl/Makefile
+@@ -45,6 +45,7 @@ obj-$(CONFIG_PINCTRL_EXYNOS5440) += pinc
obj-$(CONFIG_PINCTRL_S3C64XX) += pinctrl-s3c64xx.o
obj-$(CONFIG_PINCTRL_XWAY) += pinctrl-xway.o
obj-$(CONFIG_PINCTRL_LANTIQ) += pinctrl-lantiq.o
@@ -55,10 +49,8 @@ Index: linux-3.10.9/drivers/pinctrl/Makefile
obj-$(CONFIG_PLAT_ORION) += mvebu/
obj-$(CONFIG_ARCH_SHMOBILE) += sh-pfc/
-Index: linux-3.10.9/drivers/pinctrl/pinctrl-rt2880.c
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.9/drivers/pinctrl/pinctrl-rt2880.c 2013-08-28 16:34:43.361951711 +0200
+--- /dev/null
++++ b/drivers/pinctrl/pinctrl-rt2880.c
@@ -0,0 +1,456 @@
+/*
+ * linux/drivers/pinctrl/pinctrl-rt2880.c
@@ -516,10 +508,8 @@ Index: linux-3.10.9/drivers/pinctrl/pinctrl-rt2880.c
+}
+
+core_initcall_sync(rt2880_pinmux_init);
-Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/pinmux.h
-===================================================================
---- /dev/null 1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.10.9/arch/mips/include/asm/mach-ralink/pinmux.h 2013-08-28 16:34:43.361951711 +0200
+--- /dev/null
++++ b/arch/mips/include/asm/mach-ralink/pinmux.h
@@ -0,0 +1,47 @@
+/*
+ * This program is free software; you can redistribute it and/or modify
@@ -568,10 +558,8 @@ Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/pinmux.h
+extern struct rt2880_pmx_group *rt2880_pinmux_data;
+
+#endif
-Index: linux-3.10.9/arch/mips/ralink/mt7620.c
-===================================================================
---- linux-3.10.9.orig/arch/mips/ralink/mt7620.c 2013-08-28 16:34:42.829951688 +0200
-+++ linux-3.10.9/arch/mips/ralink/mt7620.c 2013-08-28 16:34:43.361951711 +0200
+--- a/arch/mips/ralink/mt7620.c
++++ b/arch/mips/ralink/mt7620.c
@@ -17,6 +17,7 @@
#include <asm/mipsregs.h>
#include <asm/mach-ralink/ralink_regs.h>
@@ -580,7 +568,7 @@ Index: linux-3.10.9/arch/mips/ralink/mt7620.c
#include "common.h"
-@@ -48,118 +49,40 @@
+@@ -48,118 +49,40 @@ static int dram_type;
/* the pll dividers */
static u32 mt7620_clk_divider[] = { 2, 3, 4, 8 };
@@ -732,17 +720,15 @@ Index: linux-3.10.9/arch/mips/ralink/mt7620.c
};
void __init ralink_clk_init(void)
-@@ -281,4 +204,6 @@
+@@ -281,4 +204,6 @@ void prom_soc_init(struct ralink_soc_inf
(pmu0 & PMU_SW_SET) ? ("sw") : ("hw"));
pr_info("Digital PMU set to %s control\n",
(pmu1 & DIG_SW_SEL) ? ("sw") : ("hw"));
+
+ rt2880_pinmux_data = mt7620a_pinmux_data;
}
-Index: linux-3.10.9/arch/mips/ralink/rt305x.c
-===================================================================
---- linux-3.10.9.orig/arch/mips/ralink/rt305x.c 2013-08-28 16:34:43.061951698 +0200
-+++ linux-3.10.9/arch/mips/ralink/rt305x.c 2013-08-28 16:34:43.365951713 +0200
+--- a/arch/mips/ralink/rt305x.c
++++ b/arch/mips/ralink/rt305x.c
@@ -17,90 +17,71 @@
#include <asm/mipsregs.h>
#include <asm/mach-ralink/ralink_regs.h>
@@ -892,7 +878,7 @@ Index: linux-3.10.9/arch/mips/ralink/rt305x.c
};
static void rt305x_wdt_reset(void)
-@@ -114,14 +95,6 @@
+@@ -114,14 +95,6 @@ static void rt305x_wdt_reset(void)
rt_sysc_w32(t, SYSC_REG_SYSTEM_CONFIG);
}
@@ -907,7 +893,7 @@ Index: linux-3.10.9/arch/mips/ralink/rt305x.c
static unsigned long rt5350_get_mem_size(void)
{
void __iomem *sysc = (void __iomem *) KSEG1ADDR(RT305X_SYSC_BASE);
-@@ -291,11 +264,14 @@
+@@ -291,11 +264,14 @@ void prom_soc_init(struct ralink_soc_inf
soc_info->mem_base = RT305X_SDRAM_BASE;
if (soc_is_rt5350()) {
soc_info->mem_size = rt5350_get_mem_size();
@@ -922,11 +908,9 @@ Index: linux-3.10.9/arch/mips/ralink/rt305x.c
+ rt2880_pinmux_data = rt3352_pinmux_data;
}
}
-Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/rt305x.h
-===================================================================
---- linux-3.10.9.orig/arch/mips/include/asm/mach-ralink/rt305x.h 2013-08-21 00:40:47.000000000 +0200
-+++ linux-3.10.9/arch/mips/include/asm/mach-ralink/rt305x.h 2013-08-28 16:34:43.365951713 +0200
-@@ -125,24 +125,28 @@
+--- a/arch/mips/include/asm/mach-ralink/rt305x.h
++++ b/arch/mips/include/asm/mach-ralink/rt305x.h
+@@ -125,24 +125,28 @@ static inline int soc_is_rt5350(void)
#define RT305X_GPIO_GE0_TXD0 40
#define RT305X_GPIO_GE0_RXCLK 51
@@ -970,10 +954,8 @@ Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/rt305x.h
#define RT3352_SYSC_REG_SYSCFG0 0x010
#define RT3352_SYSC_REG_SYSCFG1 0x014
-Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/mt7620.h
-===================================================================
---- linux-3.10.9.orig/arch/mips/include/asm/mach-ralink/mt7620.h 2013-08-28 16:34:42.625951682 +0200
-+++ linux-3.10.9/arch/mips/include/asm/mach-ralink/mt7620.h 2013-08-28 18:32:38.370254386 +0200
+--- a/arch/mips/include/asm/mach-ralink/mt7620.h
++++ b/arch/mips/include/asm/mach-ralink/mt7620.h
@@ -59,7 +59,6 @@
#define MT7620_DDR2_SIZE_MIN 32
#define MT7620_DDR2_SIZE_MAX 256
@@ -1010,10 +992,8 @@ Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/mt7620.h
+#define MT7620_GPIO_MODE_WDT 22
#endif
-Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/rt3883.h
-===================================================================
---- linux-3.10.9.orig/arch/mips/include/asm/mach-ralink/rt3883.h 2013-08-21 00:40:47.000000000 +0200
-+++ linux-3.10.9/arch/mips/include/asm/mach-ralink/rt3883.h 2013-08-28 18:33:57.554258201 +0200
+--- a/arch/mips/include/asm/mach-ralink/rt3883.h
++++ b/arch/mips/include/asm/mach-ralink/rt3883.h
@@ -112,8 +112,6 @@
#define RT3883_CLKCFG1_PCI_CLK_EN BIT(19)
#define RT3883_CLKCFG1_UPHY0_CLK_EN BIT(18)
@@ -1044,10 +1024,8 @@ Index: linux-3.10.9/arch/mips/include/asm/mach-ralink/rt3883.h
#define RT3883_GPIO_MODE_PCI_SHIFT 11
#define RT3883_GPIO_MODE_PCI_MASK 0x7
#define RT3883_GPIO_MODE_PCI (RT3883_GPIO_MODE_PCI_MASK << RT3883_GPIO_MODE_PCI_SHIFT)
-Index: linux-3.10.9/arch/mips/ralink/common.h
-===================================================================
---- linux-3.10.9.orig/arch/mips/ralink/common.h 2013-08-28 16:34:42.453951675 +0200
-+++ linux-3.10.9/arch/mips/ralink/common.h 2013-08-28 18:10:55.014197854 +0200
+--- a/arch/mips/ralink/common.h
++++ b/arch/mips/ralink/common.h
@@ -11,25 +11,6 @@
#define RAMIPS_SYS_TYPE_LEN 32
@@ -1074,10 +1052,8 @@ Index: linux-3.10.9/arch/mips/ralink/common.h
struct ralink_soc_info {
unsigned char sys_type[RAMIPS_SYS_TYPE_LEN];
unsigned char *compatible;
-Index: linux-3.10.9/arch/mips/ralink/rt3883.c
-===================================================================
---- linux-3.10.9.orig/arch/mips/ralink/rt3883.c 2013-08-21 00:40:47.000000000 +0200
-+++ linux-3.10.9/arch/mips/ralink/rt3883.c 2013-08-28 18:47:07.442290690 +0200
+--- a/arch/mips/ralink/rt3883.c
++++ b/arch/mips/ralink/rt3883.c
@@ -17,132 +17,50 @@
#include <asm/mipsregs.h>
#include <asm/mach-ralink/ralink_regs.h>
@@ -1249,7 +1225,7 @@ Index: linux-3.10.9/arch/mips/ralink/rt3883.c
};
static void rt3883_wdt_reset(void)
-@@ -155,17 +73,6 @@
+@@ -155,17 +73,6 @@ static void rt3883_wdt_reset(void)
rt_sysc_w32(t, RT3883_SYSC_REG_SYSCFG1);
}
@@ -1267,7 +1243,7 @@ Index: linux-3.10.9/arch/mips/ralink/rt3883.c
void __init ralink_clk_init(void)
{
unsigned long cpu_rate, sys_rate;
-@@ -243,4 +150,6 @@
+@@ -243,4 +150,6 @@ void prom_soc_init(struct ralink_soc_inf
soc_info->mem_base = RT3883_SDRAM_BASE;
soc_info->mem_size_min = RT3883_MEM_SIZE_MIN;
soc_info->mem_size_max = RT3883_MEM_SIZE_MAX;
diff --git a/target/linux/ramips/patches-3.10/0202-owrt-USB-adds-dwc_otg.patch b/target/linux/ramips/patches-3.10/0202-owrt-USB-adds-dwc_otg.patch
index 70513be3d7..5c17a665fa 100644
--- a/target/linux/ramips/patches-3.10/0202-owrt-USB-adds-dwc_otg.patch
+++ b/target/linux/ramips/patches-3.10/0202-owrt-USB-adds-dwc_otg.patch
@@ -49,9 +49,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
--- a/drivers/usb/Kconfig
+++ b/drivers/usb/Kconfig
-@@ -126,6 +126,8 @@ source "drivers/usb/core/Kconfig"
+@@ -126,6 +126,8 @@ if USB
- source "drivers/usb/dwc3/Kconfig"
+ source "drivers/usb/core/Kconfig"
+source "drivers/usb/dwc_otg/Kconfig"
+
@@ -60,8 +60,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
source "drivers/usb/wusbcore/Kconfig"
--- a/drivers/usb/Makefile
+++ b/drivers/usb/Makefile
-@@ -9,6 +9,7 @@ obj-$(CONFIG_USB) += core/
- obj-$(CONFIG_USB_OTG_UTILS) += otg/
+@@ -7,6 +7,7 @@
+ obj-$(CONFIG_USB) += core/
obj-$(CONFIG_USB_DWC3) += dwc3/
+obj-$(CONFIG_DWC_OTG) += dwc_otg/
diff --git a/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch b/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
index 4d1a4ce6fb..b03263c62c 100644
--- a/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
+++ b/target/linux/ramips/patches-3.10/0204-owrt-mtd-split-remove-padding.patch
@@ -1,6 +1,6 @@
--- a/drivers/mtd/mtdpart.c
+++ b/drivers/mtd/mtdpart.c
-@@ -808,10 +808,6 @@ static void split_uimage(struct mtd_info
+@@ -806,10 +806,6 @@ static void split_uimage(struct mtd_info
return;
len = be32_to_cpu(hdr.size) + 0x40;
diff --git a/target/linux/ramips/patches-3.10/0205-uvc-add-iPassion-iP2970-support.patch b/target/linux/ramips/patches-3.10/0205-uvc-add-iPassion-iP2970-support.patch
index 5c5cf7f596..5e3484e9e1 100644
--- a/target/linux/ramips/patches-3.10/0205-uvc-add-iPassion-iP2970-support.patch
+++ b/target/linux/ramips/patches-3.10/0205-uvc-add-iPassion-iP2970-support.patch
@@ -12,11 +12,9 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
drivers/media/usb/uvc/uvcvideo.h | 3 +++
5 files changed, 61 insertions(+), 7 deletions(-)
-Index: linux-3.10.12/drivers/media/usb/uvc/uvc_driver.c
-===================================================================
---- linux-3.10.12.orig/drivers/media/usb/uvc/uvc_driver.c 2013-09-14 15:55:12.000000000 +0200
-+++ linux-3.10.12/drivers/media/usb/uvc/uvc_driver.c 2013-09-19 04:30:11.825592123 +0200
-@@ -2420,6 +2420,20 @@
+--- a/drivers/media/usb/uvc/uvc_driver.c
++++ b/drivers/media/usb/uvc/uvc_driver.c
+@@ -2420,6 +2420,20 @@ static struct usb_device_id uvc_ids[] =
.bInterfaceProtocol = 0,
.driver_info = UVC_QUIRK_PROBE_MINMAX
| UVC_QUIRK_IGNORE_SELECTOR_UNIT },
@@ -37,11 +35,9 @@ Index: linux-3.10.12/drivers/media/usb/uvc/uvc_driver.c
/* Generic USB Video Class */
{ USB_INTERFACE_INFO(USB_CLASS_VIDEO, 1, 0) },
{}
-Index: linux-3.10.12/drivers/media/usb/uvc/uvc_status.c
-===================================================================
---- linux-3.10.12.orig/drivers/media/usb/uvc/uvc_status.c 2013-09-14 15:55:12.000000000 +0200
-+++ linux-3.10.12/drivers/media/usb/uvc/uvc_status.c 2013-09-19 01:52:55.721188742 +0200
-@@ -139,6 +139,7 @@
+--- a/drivers/media/usb/uvc/uvc_status.c
++++ b/drivers/media/usb/uvc/uvc_status.c
+@@ -139,6 +139,7 @@ static void uvc_status_complete(struct u
switch (dev->status[0] & 0x0f) {
case UVC_STATUS_TYPE_CONTROL:
uvc_event_control(dev, dev->status, len);
@@ -49,7 +45,7 @@ Index: linux-3.10.12/drivers/media/usb/uvc/uvc_status.c
break;
case UVC_STATUS_TYPE_STREAMING:
-@@ -182,6 +183,7 @@
+@@ -182,6 +183,7 @@ int uvc_status_init(struct uvc_device *d
}
pipe = usb_rcvintpipe(dev->udev, ep->desc.bEndpointAddress);
@@ -57,10 +53,8 @@ Index: linux-3.10.12/drivers/media/usb/uvc/uvc_status.c
/* For high-speed interrupt endpoints, the bInterval value is used as
* an exponent of two. Some developers forgot about it.
-Index: linux-3.10.12/drivers/media/usb/uvc/uvc_video.c
-===================================================================
---- linux-3.10.12.orig/drivers/media/usb/uvc/uvc_video.c 2013-09-14 15:55:12.000000000 +0200
-+++ linux-3.10.12/drivers/media/usb/uvc/uvc_video.c 2013-09-19 07:31:28.642057093 +0200
+--- a/drivers/media/usb/uvc/uvc_video.c
++++ b/drivers/media/usb/uvc/uvc_video.c
@@ -21,6 +21,11 @@
#include <linux/wait.h>
#include <linux/atomic.h>
@@ -73,7 +67,7 @@ Index: linux-3.10.12/drivers/media/usb/uvc/uvc_video.c
#include <media/v4l2-common.h>
-@@ -1074,9 +1079,149 @@
+@@ -1074,9 +1079,149 @@ static void uvc_video_decode_data(struct
}
}
@@ -223,7 +217,7 @@ Index: linux-3.10.12/drivers/media/usb/uvc/uvc_video.c
/* Mark the buffer as done if the EOF marker is set. */
if (data[1] & UVC_STREAM_EOF && buf->bytesused != 0) {
uvc_trace(UVC_TRACE_FRAME, "Frame complete (EOF found).\n");
-@@ -1477,6 +1622,8 @@
+@@ -1477,6 +1622,8 @@ static int uvc_init_video_isoc(struct uv
if (npackets == 0)
return -ENOMEM;
@@ -232,10 +226,8 @@ Index: linux-3.10.12/drivers/media/usb/uvc/uvc_video.c
size = npackets * psize;
for (i = 0; i < UVC_URBS; ++i) {
-Index: linux-3.10.12/drivers/media/usb/uvc/uvcvideo.h
-===================================================================
---- linux-3.10.12.orig/drivers/media/usb/uvc/uvcvideo.h 2013-09-14 15:55:12.000000000 +0200
-+++ linux-3.10.12/drivers/media/usb/uvc/uvcvideo.h 2013-09-19 04:36:51.801609222 +0200
+--- a/drivers/media/usb/uvc/uvcvideo.h
++++ b/drivers/media/usb/uvc/uvcvideo.h
@@ -137,6 +137,8 @@
#define UVC_QUIRK_FIX_BANDWIDTH 0x00000080
#define UVC_QUIRK_PROBE_DEF 0x00000100
@@ -245,7 +237,7 @@ Index: linux-3.10.12/drivers/media/usb/uvc/uvcvideo.h
/* Format flags */
#define UVC_FMT_FLAG_COMPRESSED 0x00000001
-@@ -538,6 +540,7 @@
+@@ -538,6 +540,7 @@ struct uvc_device {
__u8 *status;
struct input_dev *input;
char input_phys[64];