aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/rt288x
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-07-09 20:48:56 +0200
committerMathias Kresin <dev@kresin.me>2018-07-12 18:15:32 +0200
commitcf7154db07c0b8746be290c9e11dcab3c91d237e (patch)
tree409a783abc61a0d6622e8f76d92bd9e97705d01c /target/linux/ramips/rt288x
parent621fa91a8295b50dfdfac22290200064afaeec4e (diff)
downloadupstream-cf7154db07c0b8746be290c9e11dcab3c91d237e.tar.gz
upstream-cf7154db07c0b8746be290c9e11dcab3c91d237e.tar.bz2
upstream-cf7154db07c0b8746be290c9e11dcab3c91d237e.zip
kernel: only optimized for size if small_flash
Add a new config option to allow to select the default compile optimization level for the kernel. Select the optimization for size by default if the small_flash feature is set. Otherwise "Optimize for performance" is set. Add the small_flash feature flag to all (sub)targets which had the optimization for size in their default kernel config. Remove CC_OPTIMIZE_FOR_* symbols from all kernel configs to apply the new setting. Exceptions to the above are: - lantiq, where the optimization for size is only required for the xway_legacy subtarget but was set for the whole target - mediatek, ramips/mt7620 & ramips/mt76x8 where boards should have plenty of space and an optimization for size doesn't make much sense - rb532, which has 128MByte flash Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/rt288x')
-rw-r--r--target/linux/ramips/rt288x/config-4.142
-rw-r--r--target/linux/ramips/rt288x/target.mk1
2 files changed, 1 insertions, 2 deletions
diff --git a/target/linux/ramips/rt288x/config-4.14 b/target/linux/ramips/rt288x/config-4.14
index a4b49790a3..de4dffe885 100644
--- a/target/linux/ramips/rt288x/config-4.14
+++ b/target/linux/ramips/rt288x/config-4.14
@@ -21,8 +21,6 @@ CONFIG_ARCH_USE_QUEUED_RWLOCKS=y
CONFIG_ARCH_USE_QUEUED_SPINLOCKS=y
CONFIG_ARCH_WANT_IPC_PARSE_VERSION=y
CONFIG_BLK_MQ_PCI=y
-# CONFIG_CC_OPTIMIZE_FOR_PERFORMANCE is not set
-CONFIG_CC_OPTIMIZE_FOR_SIZE=y
CONFIG_CEVT_R4K=y
# CONFIG_CEVT_SYSTICK_QUIRK is not set
CONFIG_CLKDEV_LOOKUP=y
diff --git a/target/linux/ramips/rt288x/target.mk b/target/linux/ramips/rt288x/target.mk
index 2ca5ecfbb3..11b5a0b520 100644
--- a/target/linux/ramips/rt288x/target.mk
+++ b/target/linux/ramips/rt288x/target.mk
@@ -4,6 +4,7 @@
SUBTARGET:=rt288x
BOARDNAME:=RT288x based boards
+FEATURES+=small_flash
CPU_TYPE:=24kc
DEFAULT_PACKAGES += kmod-rt2800-soc wpad-mini