aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-4.4
diff options
context:
space:
mode:
authorStijn Segers <francesco.borromini@inventati.org>2016-09-30 08:34:01 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-09-30 13:34:04 +0200
commit949cfbb24374be151e2c01db09dd98bc8537a989 (patch)
tree8a87fc4295daec2beee33827e85592f2b932a791 /target/linux/ramips/patches-4.4
parentfc88eb3fdfce6d39b4c62158cf6f42605a360a1e (diff)
downloadupstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.gz
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.tar.bz2
upstream-949cfbb24374be151e2c01db09dd98bc8537a989.zip
kernel: update kernel 4.4 to version 4.4.22
Forgot to update kernel-version.mk, so updated patch. Compile-tested on x86/64 and ar71xx; run-tested on x86/64 and ar71xx. Signed-off-by: Stijn Segers <francesco.borromini@inventati.org>
Diffstat (limited to 'target/linux/ramips/patches-4.4')
-rw-r--r--target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch4
-rw-r--r--target/linux/ramips/patches-4.4/0200-linkit_bootstrap.patch2
2 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch b/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch
index 5e5cfe2065..1bd29747b8 100644
--- a/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch
+++ b/target/linux/ramips/patches-4.4/0033-xhci-mediatek-support-MTK-xHCI-host-controller.patch
@@ -1420,7 +1420,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
/*
* Returns zero if the TRB isn't in this segment, otherwise it returns the DMA
-@@ -3084,17 +3085,22 @@ static u32 xhci_td_remainder(struct xhci
+@@ -3088,17 +3089,22 @@ static u32 xhci_td_remainder(struct xhci
{
u32 maxp, total_packet_count;
@@ -1447,7 +1447,7 @@ Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
/* Queueing functions don't count the current TRB into transferred */
return (total_packet_count - ((transferred + trb_buff_len) / maxp));
}
-@@ -3482,7 +3488,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
+@@ -3486,7 +3492,7 @@ int xhci_queue_ctrl_tx(struct xhci_hcd *
field |= 0x1;
/* xHCI 1.0/1.1 6.4.1.2.1: Transfer Type field */
diff --git a/target/linux/ramips/patches-4.4/0200-linkit_bootstrap.patch b/target/linux/ramips/patches-4.4/0200-linkit_bootstrap.patch
index 70e8170c44..6e11075d54 100644
--- a/target/linux/ramips/patches-4.4/0200-linkit_bootstrap.patch
+++ b/target/linux/ramips/patches-4.4/0200-linkit_bootstrap.patch
@@ -1,6 +1,6 @@
--- a/drivers/misc/Makefile
+++ b/drivers/misc/Makefile
-@@ -56,3 +56,4 @@ obj-$(CONFIG_GENWQE) += genwqe/
+@@ -57,3 +57,4 @@ obj-$(CONFIG_GENWQE) += genwqe/
obj-$(CONFIG_ECHO) += echo/
obj-$(CONFIG_VEXPRESS_SYSCFG) += vexpress-syscfg.o
obj-$(CONFIG_CXL_BASE) += cxl/