aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-02-12 12:52:14 +0000
commita287c60a61bbad21af22523ca50281850dd1e2c1 (patch)
tree96d48290c14dd4976311bb801c031b68285a74f2 /target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
parent388013b0ce70c0cc7a40d031a8f94188f1214ad0 (diff)
downloadupstream-a287c60a61bbad21af22523ca50281850dd1e2c1.tar.gz
upstream-a287c60a61bbad21af22523ca50281850dd1e2c1.tar.bz2
upstream-a287c60a61bbad21af22523ca50281850dd1e2c1.zip
ramips: add initial support for 3.2
SVN-Revision: 30476
Diffstat (limited to 'target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch b/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
new file mode 100644
index 0000000000..293044dabd
--- /dev/null
+++ b/target/linux/ramips/patches-3.2/104-ramips-watchdog-driver.patch
@@ -0,0 +1,26 @@
+--- a/drivers/watchdog/Kconfig
++++ b/drivers/watchdog/Kconfig
+@@ -1020,6 +1020,13 @@ config LANTIQ_WDT
+ help
+ Hardware driver for the Lantiq SoC Watchdog Timer.
+
++config RAMIPS_WDT
++ tristate "Ralink RT288X/RT305X Watchdog Timer"
++ depends on SOC_RT288X || SOC_RT305X
++ help
++ Hardware driver for the built-in watchdog timer on the
++ Ralink RT288X/RT305X SoCs.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture
+--- a/drivers/watchdog/Makefile
++++ b/drivers/watchdog/Makefile
+@@ -131,6 +131,7 @@ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
+ obj-$(CONFIG_OCTEON_WDT) += octeon-wdt.o
+ octeon-wdt-y := octeon-wdt-main.o octeon-wdt-nmi.o
+ obj-$(CONFIG_LANTIQ_WDT) += lantiq_wdt.o
++obj-$(CONFIG_RAMIPS_WDT) += ramips_wdt.o
+
+ # PARISC Architecture
+