aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2014-01-11 16:06:37 +0000
committerGabor Juhos <juhosg@openwrt.org>2014-01-11 16:06:37 +0000
commit0e2586a7748385c97062a8d8816c98011175fb3d (patch)
tree819954dd504b84d34aba5e827e06e5b319ddc393 /target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch
parent30ebad2dee1bc348c9b8234f0649a0b8f7a9cb40 (diff)
downloadupstream-0e2586a7748385c97062a8d8816c98011175fb3d.tar.gz
upstream-0e2586a7748385c97062a8d8816c98011175fb3d.tar.bz2
upstream-0e2586a7748385c97062a8d8816c98011175fb3d.zip
kernel: update 3.10 to 3.10.26
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> SVN-Revision: 39220
Diffstat (limited to 'target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch')
-rw-r--r--target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch14
1 files changed, 3 insertions, 11 deletions
diff --git a/target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch b/target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch
index 084a531234..3ca3c9dbaf 100644
--- a/target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch
+++ b/target/linux/ramips/patches-3.10/0504-MIPS-ralink-add-pcie-driver.patch
@@ -10,21 +10,16 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
2 files changed, 798 insertions(+)
create mode 100644 arch/mips/pci/pci-mt7621.c
-diff --git a/arch/mips/pci/Makefile b/arch/mips/pci/Makefile
-index 719e455..80886fe 100644
--- a/arch/mips/pci/Makefile
+++ b/arch/mips/pci/Makefile
-@@ -42,6 +42,7 @@ obj-$(CONFIG_SNI_RM) += fixup-sni.o ops-sni.o
- obj-$(CONFIG_LANTIQ) += fixup-lantiq.o
- obj-$(CONFIG_PCI_LANTIQ) += pci-lantiq.o ops-lantiq.o
+@@ -44,6 +44,7 @@ obj-$(CONFIG_PCI_LANTIQ) += pci-lantiq.o
+ obj-$(CONFIG_SOC_MT7620) += pci-mt7620a.o
+ obj-$(CONFIG_SOC_RT2880) += pci-rt2880.o
obj-$(CONFIG_SOC_RT3883) += pci-rt3883.o
+obj-$(CONFIG_SOC_MT7621) += pci-mt7621.o
obj-$(CONFIG_TANBAC_TB0219) += fixup-tb0219.o
obj-$(CONFIG_TANBAC_TB0226) += fixup-tb0226.o
obj-$(CONFIG_TANBAC_TB0287) += fixup-tb0287.o
-diff --git a/arch/mips/pci/pci-mt7621.c b/arch/mips/pci/pci-mt7621.c
-new file mode 100644
-index 0000000..0b58fce
--- /dev/null
+++ b/arch/mips/pci/pci-mt7621.c
@@ -0,0 +1,797 @@
@@ -825,6 +820,3 @@ index 0000000..0b58fce
+{
+ return 0;
+}
---
-1.7.10.4
-