aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/mt7621/base-files
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-07 10:47:18 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-12 13:25:42 +0200
commite8931b309f82a44b55e64af3668186cdf7bcde15 (patch)
tree756df8b4b54a73b2f4acd69ec48df19fe29b5410 /target/linux/ramips/mt7621/base-files
parentbebc9809d15b0ddc018d379f5caa3a11c9a06786 (diff)
downloadupstream-e8931b309f82a44b55e64af3668186cdf7bcde15.tar.gz
upstream-e8931b309f82a44b55e64af3668186cdf7bcde15.tar.bz2
upstream-e8931b309f82a44b55e64af3668186cdf7bcde15.zip
ramips: mt7621: tidy up names for Ubiquiti devices
The "proper" vendor prefix for Ubiquiti is "ubnt", this is used in all targets except ramips and also recommended by the kernel. This patch adjusts the various board/image/device name variables accordingly. Since we touch it anyway, this also adds the space in "EdgeRouter X" as a hyphen to those variables to really make them consistent with the model name. While at it, create a real shared definition for the devices in image/mt7621.mk instead of deriving one device from another. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target/linux/ramips/mt7621/base-files')
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/02_network4
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches4
-rw-r--r--target/linux/ramips/mt7621/base-files/lib/preinit/07_mt7621_bringup_dsa_master4
-rwxr-xr-xtarget/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh4
4 files changed, 8 insertions, 8 deletions
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
index f573a049ce..252f9f1dda 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/02_network
@@ -42,8 +42,8 @@ ramips_setup_interfaces()
mikrotik,routerboard-750gr3)
ucidef_set_interfaces_lan_wan "lan2 lan3 lan4 lan5" "wan"
;;
- ubiquiti,edgerouterx|\
- ubiquiti,edgerouterx-sfp)
+ ubnt,edgerouter-x|\
+ ubnt,edgerouter-x-sfp)
ucidef_set_interface_lan "eth0 eth1 eth2 eth3 eth4"
;;
*)
diff --git a/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches b/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
index 511d9deed8..91a9459d8c 100755
--- a/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
+++ b/target/linux/ramips/mt7621/base-files/etc/board.d/03_gpio_switches
@@ -13,10 +13,10 @@ mikrotik,routerboard-750gr3)
telco-electronics,x1)
ucidef_add_gpio_switch "modem_reset" "Modem Reset" "16"
;;
-ubiquiti,edgerouterx)
+ubnt,edgerouter-x)
ucidef_add_gpio_switch "poe_passthrough" "PoE Passthrough" "0"
;;
-ubiquiti,edgerouterx-sfp)
+ubnt,edgerouter-x-sfp)
ucidef_add_gpio_switch "poe_power_port0" "PoE Power Port0" "496"
ucidef_add_gpio_switch "poe_power_port1" "PoE Power Port1" "497"
ucidef_add_gpio_switch "poe_power_port2" "PoE Power Port2" "498"
diff --git a/target/linux/ramips/mt7621/base-files/lib/preinit/07_mt7621_bringup_dsa_master b/target/linux/ramips/mt7621/base-files/lib/preinit/07_mt7621_bringup_dsa_master
index 7a11252168..b8ebcc3f41 100644
--- a/target/linux/ramips/mt7621/base-files/lib/preinit/07_mt7621_bringup_dsa_master
+++ b/target/linux/ramips/mt7621/base-files/lib/preinit/07_mt7621_bringup_dsa_master
@@ -7,8 +7,8 @@ mt7621_bringup_dsa_master() {
local masterif
case "$board" in
- ubiquiti,edgerouterx|\
- ubiquiti,edgerouterx-sfp)
+ ubnt,edgerouter-x|\
+ ubnt,edgerouter-x-sfp)
masterif="dsa"
;;
*)
diff --git a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
index 3f292a5dac..864c59c8e5 100755
--- a/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/mt7621/base-files/lib/upgrade/platform.sh
@@ -62,8 +62,8 @@ platform_do_upgrade() {
iodata_mstc_upgrade_prepare
nand_do_upgrade "$1"
;;
- ubiquiti,edgerouterx|\
- ubiquiti,edgerouterx-sfp)
+ ubnt,edgerouter-x|\
+ ubnt,edgerouter-x-sfp)
platform_upgrade_ubnt_erx "$1"
;;
*)