aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-04-08 11:49:02 +0200
committerMathias Kresin <dev@kresin.me>2018-04-08 12:35:33 +0200
commitdda5d9b78643ca2a943759278c2ef50d595cb509 (patch)
tree82838677a24197215c0d6007eac778d123e9b9ab /target/linux/ramips/modules.mk
parentbcf21251425de261a64a27fe21529d2ddbcc13d5 (diff)
downloadupstream-dda5d9b78643ca2a943759278c2ef50d595cb509.tar.gz
upstream-dda5d9b78643ca2a943759278c2ef50d595cb509.tar.bz2
upstream-dda5d9b78643ca2a943759278c2ef50d595cb509.zip
ramips: rename pwm kernel module
With kernel 4.14 the OpenWrt specific module name collides with the upstream added module for Mediatek ARM Socs. During addition of preliminary support for kernel 4.14, the config symbol used by the out of tree driver was already renamed but the ramips kernel package wasn't updated. Fix the build error by updating the config and kernel module name for the kernel package. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk10
1 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 95dfd78d05..88e83a487f 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -7,24 +7,24 @@
OTHER_MENU:=Other modules
-define KernelPackage/pwm-mediatek
+define KernelPackage/pwm-mediatek-ramips
SUBMENU:=Other modules
TITLE:=MT7628 PWM
DEPENDS:=@(TARGET_ramips_mt76x8)
KCONFIG:= \
CONFIG_PWM=y \
- CONFIG_PWM_MEDIATEK \
+ CONFIG_PWM_MEDIATEK_RAMIPS \
CONFIG_PWM_SYSFS=y
FILES:= \
- $(LINUX_DIR)/drivers/pwm/pwm-mediatek.ko
- AUTOLOAD:=$(call AutoProbe,pwm-mediatek)
+ $(LINUX_DIR)/drivers/pwm/pwm-mediatek-ramips.ko
+ AUTOLOAD:=$(call AutoProbe,pwm-mediatek-ramips)
endef
define KernelPackage/pwm-mediatek/description
Kernel modules for MediaTek Pulse Width Modulator
endef
-$(eval $(call KernelPackage,pwm-mediatek))
+$(eval $(call KernelPackage,pwm-mediatek-ramips))
define KernelPackage/sdhci-mt7620
SUBMENU:=Other modules