aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorFurong Xu <xfr@outlook.com>2017-03-03 14:07:34 +0800
committerJohn Crispin <john@phrozen.org>2017-03-11 08:19:37 +0100
commita93a48328d092e4d097bf6b218dfe531d92b803a (patch)
tree80780a8212a7f5e6c485ed2f5d229a897af4ce8c /target/linux/ramips/modules.mk
parent0e56151ab24fe79677a845d2eb173fc336133752 (diff)
downloadupstream-a93a48328d092e4d097bf6b218dfe531d92b803a.tar.gz
upstream-a93a48328d092e4d097bf6b218dfe531d92b803a.tar.bz2
upstream-a93a48328d092e4d097bf6b218dfe531d92b803a.zip
ramips: kmod-sdhci-mt7620: switch dependence to kmod-mmc
mtk-mmc/mtk_sd.ko only depends on mmc_core and mmc_block. And, we remove kmod-sdhci dependence assignment from all related target devices. Signed-off-by: Furong Xu <xfr@outlook.com>
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 2bece6fc5c..524b1ef4fd 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,pwm-mediatek))
define KernelPackage/sdhci-mt7620
SUBMENU:=Other modules
TITLE:=MT7620 SDCI
- DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt7628||TARGET_ramips_mt7621||TARGET_ramips_mt7688) +kmod-sdhci
+ DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt7628||TARGET_ramips_mt7621||TARGET_ramips_mt7688) +kmod-mmc
KCONFIG:= \
CONFIG_MTK_MMC \
CONFIG_MTK_AEE_KDUMP=n \