aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2017-01-13 07:14:38 -0800
committerJohn Crispin <john@phrozen.org>2017-01-15 17:43:05 +0100
commit80768ddccd6275d1506badcf57ae31560ca19da2 (patch)
tree0e642e39d95995a55740d5fd4130a4fd97ac6cd1 /target/linux/ramips/modules.mk
parent26e4fee6e28d5f5d50a5ce74aa044fa5b3a9db65 (diff)
downloadupstream-80768ddccd6275d1506badcf57ae31560ca19da2.tar.gz
upstream-80768ddccd6275d1506badcf57ae31560ca19da2.tar.bz2
upstream-80768ddccd6275d1506badcf57ae31560ca19da2.zip
ramips: Add I2C driver to the default kernel config
I made a commit that added the RTC driver to the kernel config with the intent that it would fix hctosys. Unfortunately while the RTC driver is in there, it's connected through I2C, the driver for which comes in module form and is thus loaded late. After this commit, it works fine. Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk16
1 files changed, 0 insertions, 16 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 99c5a9d0fc..c2b6f50624 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -58,22 +58,6 @@ endef
$(eval $(call KernelPackage,i2c-ralink))
-I2C_MT7621_MODULES:= \
- CONFIG_I2C_MT7621:drivers/i2c/busses/i2c-mt7621
-
-define KernelPackage/i2c-mt7621
- $(call i2c_defaults,$(I2C_MT7621_MODULES),59)
- TITLE:=MT7621 I2C Controller
- DEPENDS:=kmod-i2c-core \
- @(TARGET_ramips_mt7621||TARGET_ramips_mt7628||TARGET_ramips_mt7688)
-endef
-
-define KernelPackage/i2c-mt7621/description
- Kernel modules for enable mt7621 i2c controller.
-endef
-
-$(eval $(call KernelPackage,i2c-mt7621))
-
define KernelPackage/dma-ralink
SUBMENU:=Other modules
TITLE:=Ralink GDMA Engine