aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/modules.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@phrozen.org>2017-09-05 08:08:36 +0200
committerJohn Crispin <john@phrozen.org>2017-09-05 08:08:36 +0200
commit5117911d91c0d047971f592086dc6b9be65b5103 (patch)
treeca635212f676515809e61eea2f6db7173b5f4ad8 /target/linux/ramips/modules.mk
parent69323a0c070523fb7193486c4f89546668a72de8 (diff)
downloadupstream-5117911d91c0d047971f592086dc6b9be65b5103.tar.gz
upstream-5117911d91c0d047971f592086dc6b9be65b5103.tar.bz2
upstream-5117911d91c0d047971f592086dc6b9be65b5103.zip
ramips: fix mt76x8 dependencies
The commit merging mt7628 and mt7688 failed to update some dependencies. Signed-off-by: John Crispin <john@phrozen.org>
Diffstat (limited to 'target/linux/ramips/modules.mk')
-rw-r--r--target/linux/ramips/modules.mk8
1 files changed, 4 insertions, 4 deletions
diff --git a/target/linux/ramips/modules.mk b/target/linux/ramips/modules.mk
index 870f2d5c43..95dfd78d05 100644
--- a/target/linux/ramips/modules.mk
+++ b/target/linux/ramips/modules.mk
@@ -10,7 +10,7 @@ OTHER_MENU:=Other modules
define KernelPackage/pwm-mediatek
SUBMENU:=Other modules
TITLE:=MT7628 PWM
- DEPENDS:=@(TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+ DEPENDS:=@(TARGET_ramips_mt76x8)
KCONFIG:= \
CONFIG_PWM=y \
CONFIG_PWM_MEDIATEK \
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,pwm-mediatek))
define KernelPackage/sdhci-mt7620
SUBMENU:=Other modules
TITLE:=MT7620 SDCI
- DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt7628||TARGET_ramips_mt7621||TARGET_ramips_mt7688) +kmod-mmc
+ DEPENDS:=@(TARGET_ramips_mt7620||TARGET_ramips_mt76x8||TARGET_ramips_mt7621) +kmod-mmc
KCONFIG:= \
CONFIG_MTK_MMC \
CONFIG_MTK_AEE_KDUMP=n \
@@ -48,7 +48,7 @@ define KernelPackage/i2c-ralink
$(call i2c_defaults,$(I2C_RALINK_MODULES),59)
TITLE:=Ralink I2C Controller
DEPENDS:=kmod-i2c-core @TARGET_ramips \
- @!(TARGET_ramips_mt7621||TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+ @!(TARGET_ramips_mt7621||TARGET_ramips_mt76x8)
endef
define KernelPackage/i2c-ralink/description
@@ -65,7 +65,7 @@ define KernelPackage/i2c-mt7628
$(call i2c_defaults,$(I2C_MT7621_MODULES),59)
TITLE:=MT7628/88 I2C Controller
DEPENDS:=kmod-i2c-core \
- @(TARGET_ramips_mt7628||TARGET_ramips_mt7688)
+ @(TARGET_ramips_mt76x8)
endef
define KernelPackage/i2c-mt7628/description