aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorDavid Bauer <mail@david-bauer.net>2023-03-23 23:53:47 +0100
committerDavid Bauer <mail@david-bauer.net>2023-03-24 16:04:38 +0100
commitf5db04e8ea8377046a86885fdd5a83e948b54918 (patch)
treefde0f16a05730ff994c62c85be1cf29b383cd663 /target/linux/ramips/image
parentc58959dc45a0396dcd4afe0a066f7d466f48a8a9 (diff)
downloadupstream-f5db04e8ea8377046a86885fdd5a83e948b54918.tar.gz
upstream-f5db04e8ea8377046a86885fdd5a83e948b54918.tar.bz2
upstream-f5db04e8ea8377046a86885fdd5a83e948b54918.zip
ramips: add support for Mercusys MR70X
Hardware ======== - SoC: MediaTek MT7621AT (880MHz, Duel-Core) - RAM: DDR3 128MB - Flash: Winbond W25Q128JV (SPI-NOR 16MB) - WiFi: MediaTek MT7915D (2.4GHz, 5GHz, DBDC) - Ethernet: MediaTek MT7530 (WAN x1, LAN x3, SoC) - UART: >TX RX GND 3v3 (115200 8N1, J1) Do not connect 3v3. TX is marked with an arrow. Installation ============ Flash factory image. This can be done using stock web ui. Revert to stock firmware ======================== Flash stock firmware via OEM Web UI Recovery mode. Web UI Recovery method ====================== 1. Unplug the router 2. Plug in and hold reset button 5~10 secs 3. Set your computer IP address manually to 192.168.1.x / 255.255.255.0 4. Flash image with web browser to 192.168.1.1 Co-authored-by: Robert Senderek <robert.senderek@10g.pl> Co-authored-by: Yoonji Park <koreapyj@dcmys.kr> Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 47de2c686291e69afc9f443e27e1dfd11ed5fbe7)
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 11a1e4cb6a..df2b935c88 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1143,6 +1143,19 @@ define Device/mediatek_mt7621-eval-board
endef
TARGET_DEVICES += mediatek_mt7621-eval-board
+define Device/mercusys_mr70x-v1
+ $(Device/dsa-migration)
+ $(Device/tplink-safeloader)
+ DEVICE_VENDOR := Mercusys
+ DEVICE_MODEL := MR70X
+ DEVICE_VARIANT := v1
+ DEVICE_PACKAGES := kmod-mt7915e -uboot-envtools
+ TPLINK_BOARD_ID := MR70X
+ KERNEL := $(KERNEL_DTB) | uImage lzma
+ IMAGE_SIZE := 15744k
+endef
+TARGET_DEVICES += mercusys_mr70x-v1
+
define Device/MikroTik
$(Device/dsa-migration)
DEVICE_VENDOR := MikroTik