aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2018-11-26 13:26:06 +0100
committerMathias Kresin <dev@kresin.me>2018-11-26 15:54:22 +0100
commite4d9217fe5419364d2fe89e69c2e4f9f47fd30b6 (patch)
treee93978c5c23647a5a3a47900ee5eef0c300f5756 /target/linux/ramips/image
parent71ba834cf1a1c8fcbf345b7efa75de0dcba9db20 (diff)
downloadupstream-e4d9217fe5419364d2fe89e69c2e4f9f47fd30b6.tar.gz
upstream-e4d9217fe5419364d2fe89e69c2e4f9f47fd30b6.tar.bz2
upstream-e4d9217fe5419364d2fe89e69c2e4f9f47fd30b6.zip
ramips: improve BDCOM WAP2100-SK support
Use the generic board detection instead of the target specific one as all recent additions are doing. Setup the USB led via devicetree (a58535771f11) and include the required driver by default. Merge the led userspace setting with an existing identical case. Use the wps led for boot status indication. Move the partitions into a partition table node (6031ab345df8) and drop needless labels. Drop misplaced cells properties (53624c1702e6). Cleanup the pinmux and only switch pins to gpio functions which a referenced as gpio in the dts. Match the maximum image size with the size of the firmware partition. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 5e3d37b5c8..bf04a75ea1 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -80,14 +80,13 @@ define Device/ArcherMR200
endef
TARGET_DEVICES += ArcherMR200
-define Device/BDCOM-WAP2100-SK
+define Device/bdcom_wap2100-sk
DTS := BDCOM-WAP2100-SK
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
- SUPPORTED_DEVICES += wap2100-sk
+ IMAGE_SIZE := 15808k
DEVICE_TITLE := BDCOM WAP2100-SK (ZTE ZXECS EBG3130)
- DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-mt76 kmod-sdhci-mt7620 kmod-usb-ledtrig-usbport
endef
-TARGET_DEVICES += BDCOM-WAP2100-SK
+TARGET_DEVICES += bdcom_wap2100-sk
define Device/bocco
DTS := BOCCO