aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorLars Wessels <software@bytebox.org>2020-06-25 21:09:59 +0200
committerDavid Bauer <mail@david-bauer.net>2020-06-29 01:08:01 +0200
commitdbaf0d20bb6afec4a592456af6b1238b46fa1acb (patch)
tree6d6d2a66cc28bfc036847f375d947ff164fdcf51 /target/linux/ramips/image
parent5234593462bc72582fafd0769d3b679f9b598574 (diff)
downloadupstream-dbaf0d20bb6afec4a592456af6b1238b46fa1acb.tar.gz
upstream-dbaf0d20bb6afec4a592456af6b1238b46fa1acb.tar.bz2
upstream-dbaf0d20bb6afec4a592456af6b1238b46fa1acb.zip
ramips: add support for WAVLINK WL-WN577A2
This commit adds support for the Wavlink WL-WN577A2 (black case) dual-band wall-plug wireless router. In Germany this device is sold under the brand name Maginon WL-755 (white case): Device specifications: - CPU: MediaTek MT7628AN (580MHz) - Flash: 8MB - RAM: 64MB - Bootloader: U-Boot - Ethernet: 2x 10/100 Mbps (Ralink RT3050) - 2.4 GHz: 802.11b/g/n SoC - 5 GHz: 802.11a/n/ac MT7610E - Antennas: internal - 4 green LEDs: 1 programmable (WPS) + LAN, WAN, POWER - Buttons: Reset, WPS - Small sliding power switch Flashing instructions (U-boot): - Configure a TFTP server on your PC/Laptop and set its IP to 192.168.10.100 - Rename the OpenWrt image to firmware.bin and place it in the root folder of the TFTP server - Power off (using the small sliding power switch on the left side) the device and connect an ethernet cable from its LAN or WAN port to your PC/Laptop - Press the WPS button (and keep it pressed) - Power on the device (using the small power switch) - After a few seconds, when the WAN/LAN LED stops blinking very fast, release the WPS button - Flashing OpenWrt takes less than a minute, system will reboot automatically - After reboot the WPS LED will indicate the current OpenWrt running status Signed-off-by: Lars Wessels <software@bytebox.org> [removed unused labels - fix whitespace errors - wrap commit message] Signed-off-by: David Bauer <mail@david-bauer.net>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index a18afefd74..605537ace3 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -556,6 +556,16 @@ define Device/wavlink_wl-wn575a3
endef
TARGET_DEVICES += wavlink_wl-wn575a3
+define Device/wavlink_wl-wn577a2
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := Wavlink
+ DEVICE_MODEL := WL-WN577A2
+ DEVICE_ALT0_VENDOR := Maginon
+ DEVICE_ALT0_MODEL := WLR-755
+ DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += wavlink_wl-wn577a2
+
define Device/widora_neo-16m
IMAGE_SIZE := 16064k
DEVICE_VENDOR := Widora