aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorMathieu Martin-Borret <mathieu.mb@protonmail.com>2020-07-10 13:49:20 +1000
committerPetr Štetiar <ynezz@true.cz>2020-07-13 22:45:04 +0200
commitd7233b0a6a9b8cb9207a74a8cb3d0525170cf504 (patch)
treed6fa6c1a394b611a3c6bb013410e6d2c924cc5b5 /target/linux/ramips/image
parent96761ecc2f998e0ae082719ed27adbecd12e520f (diff)
downloadupstream-d7233b0a6a9b8cb9207a74a8cb3d0525170cf504.tar.gz
upstream-d7233b0a6a9b8cb9207a74a8cb3d0525170cf504.tar.bz2
upstream-d7233b0a6a9b8cb9207a74a8cb3d0525170cf504.zip
ramips: add support for D-Link DIR-878 A1
Specifications: SoC: MT7621AT RAM: 128MB Flash: 16MB NOR SPI flash WiFi: MT7615N (2.4GHz) and MT7615N (5Ghz) LAN: 5x1000M Firmware layout is Uboot with extra 96 bytes in header Base PCB is AP-MTKH7-0002 LEDs Power Green,Power Orange,Internet Green,Internet Orange LEDs "2.4G" Green & "5G" Green connected directly to wifi module Buttons Reset,WPS,WIFI Flashing instructions: Upload image via emergency recovery mode Push and hold reset button (on the back of the device) until power led starts flashing (about 10 secs or so) while powering the device on. Give it ~30 seconds, to boot the recovery mode GUI Connect your client computer to LAN1 of the device Set your client IP address manually to 192.168.0.2 / 255.255.255.0. Call the recovery page for the device at http://192.168.0.1 Use the provided emergency web GUI to upload and flash a new firmware to the device. Some browsers/OS combinations are known not to work, so if you don't see the percentage complete displayed and moving within a few seconds, restart the procedure from scratch and try anoher one, or try the command line way. Alternative method using command line on Linux: curl -v -i -F "firmware=@openwrt-xxxx-squashfs-factory.bin" 192.168.0.1 Signed-off-by: Mathieu Martin-Borret <mathieu.mb@protonmail.com> [use of generic uimage-padhdr in image generation code] Signed-off-by: Petr Štetiar <ynezz@true.cz>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 9e5bd811b0..48561d5ff9 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -236,6 +236,21 @@ define Device/dlink_dir-860l-b1
endef
TARGET_DEVICES += dlink_dir-860l-b1
+define Device/dlink_dir-878-a1
+ IMAGE_SIZE := 16000k
+ DEVICE_VENDOR := D-Link
+ DEVICE_MODEL := DIR-878
+ DEVICE_VARIANT := A1
+ DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware wpad-basic
+ KERNEL_INITRAMFS := $$(KERNEL) | uimage-padhdr 96
+ IMAGES += factory.bin
+ IMAGE/sysupgrade.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
+ pad-rootfs | append-metadata | check-size
+ IMAGE/factory.bin := append-kernel | append-rootfs | uimage-padhdr 96 |\
+ check-size
+endef
+TARGET_DEVICES += dlink_dir-878-a1
+
define Device/d-team_newifi-d2
$(Device/uimage-lzma-loader)
IMAGE_SIZE := 32448k