aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2011-04-04 08:43:07 +0000
committerGabor Juhos <juhosg@openwrt.org>2011-04-04 08:43:07 +0000
commitd5a7e2f5c1d63e81771617940ac6f92b31a05583 (patch)
tree07f7373ae8a5ae6b4ee515e7beb88e72a04f53bd /target/linux/ramips/image
parent490032400b7233fad90840ed83ae8df3566f0b93 (diff)
downloadupstream-d5a7e2f5c1d63e81771617940ac6f92b31a05583.tar.gz
upstream-d5a7e2f5c1d63e81771617940ac6f92b31a05583.tar.bz2
upstream-d5a7e2f5c1d63e81771617940ac6f92b31a05583.zip
ramips: initial board support for MOFI3500-3GN
This patch adds initial board support for the MoFi Network MOFI3500-3GN (Ralink RT3052F SoC, 8MB flash, 32MB ram, wireless N, USB-OTG). This router is basically the NA version of the HW550-3G. Signed-off-by: Layne Edwards <ledwards76@gmail.com> SVN-Revision: 26466
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 361588efcf..224e4111ef 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -104,6 +104,9 @@ define Image/Build/Profile/HW5503G
$(call Image/Build/Template/GENERIC_8M,$(1),hw550-3g,HW550-3G)
endef
+define Image/Build/Profile/MOFI35003GN
+ $(call Image/Build/Template/GENERIC_8M,$(1),mofi3500-3gn,MOFI3500-3GN)
+endef
mtdlayout_wcr150gn=mtdparts=physmap-flash.0:192k(Bootloader)ro,64k(Config),64k(Factory),832k(Kernel),2944k(rootfs),3776k@0x50000(firmware)
mtd_wcr150gn_kernel_part_size=851968
@@ -139,6 +142,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/WCR150GN,$(1))
$(call Image/Build/Profile/F5D8235V2,$(1))
$(call Image/Build/Profile/HW5503G,$(1))
+ $(call Image/Build/Profile/MOFI35003GN,$(1))
endef
endif