aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorWang JiaWei <buaawjw@gmail.com>2017-02-25 07:19:15 +0800
committerJohn Crispin <john@phrozen.org>2017-02-27 11:39:31 +0100
commitd48cc5e0449fec6f7717e85a68f06a61abd7b0ae (patch)
tree83394e03b06be9c57df044f3f3e66a03ccf14c12 /target/linux/ramips/image
parenta0a9ba046492e952aa5cab042d96bec4cab6e17f (diff)
downloadupstream-d48cc5e0449fec6f7717e85a68f06a61abd7b0ae.tar.gz
upstream-d48cc5e0449fec6f7717e85a68f06a61abd7b0ae.tar.bz2
upstream-d48cc5e0449fec6f7717e85a68f06a61abd7b0ae.zip
ramips: add support for HiWiFi HC5661A
HC5661A is almost the same as HC5661 but MT7628AN is used instead of MT7620A. - MT7628AN - 128 MiB DDR2 RAM (W971GG6KB-25) - 16 MiB SPI NOR flash (W25Q128) - SD slot (not work yet) - 1+4 x 100M Ethernet - 802.11 b/g/n Wi-Fi - 3 x LED - 1 x button - UART pad on PCB (JP1: TX, RX, GND, 3.3V) The factory flash layout seems different from HC5661. "hwf_config" is renamed to "oem" and its size changes to 0x20000. It is modified accordingly in the dts file. 0x000000000000-0x000000030000 : "u-boot" 0x000000030000-0x000000040000 : "hw_panic" 0x000000040000-0x000000050000 : "Factory" 0x000000050000-0x000000160000 : "kernel" 0x000000160000-0x000000fc0000 : "rootfs" 0x000000bb0000-0x000000fc0000 : "rootfs_data" 0x000000fc0000-0x000000fe0000 : "oem" 0x000000fe0000-0x000000ff0000 : "bdinfo" 0x000000ff0000-0x000001000000 : "backup" 0x000000050000-0x000000fc0000 : "firmware" To install LEDE, enabled the "developer mode", which will *void your warranty* and open the SSH server at port 1022. sysupgrade -n -F lede-ramips-mt7628-hc5661a-squashfs-sysupgrade.bin SD slot: - Tried to add modules kmod-sdhci kmod-sdhci-mt7620, and corresponding dts block. - It will block WAN + 3xLAN ports, only one LAN works. - I'm not sure why, everything else works fine. Signed-off-by: Wang JiaWei <buaawjw@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7628.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
index 0304921f41..6292d45562 100644
--- a/target/linux/ramips/image/mt7628.mk
+++ b/target/linux/ramips/image/mt7628.mk
@@ -11,6 +11,13 @@ define Device/mt7628
endef
TARGET_DEVICES += mt7628
+define Device/hc5661a
+ DTS := HC5661A
+ IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ DEVICE_TITLE := HiWiFi HC5661A
+endef
+TARGET_DEVICES += hc5661a
+
define Device/miwifi-nano
DTS := MIWIFI-NANO
IMAGE_SIZE := $(ralink_default_fw_size_16M)