aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorAleksey Nasibulin <alealexpro100@ya.ru>2023-03-06 10:49:33 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2023-03-08 23:44:59 +0100
commitd45659a571645f98674845e5efd07f447de337ed (patch)
treefef5a92ff6157c1b622a3601ec65143330a3f0aa /target/linux/ramips/image
parentbf055fcdca155993b9b6c82f951000eefb13288a (diff)
downloadupstream-d45659a571645f98674845e5efd07f447de337ed.tar.gz
upstream-d45659a571645f98674845e5efd07f447de337ed.tar.bz2
upstream-d45659a571645f98674845e5efd07f447de337ed.zip
ramips: add support for SNR-CPE-ME2-SFP
SNR-CPE-ME2-SFP is a wireless router with SFP cage manufactured by SNR/NAG company. Specification: - SoC: MediaTek MT7621A - CPU: 880MHz - Flash: 16 MB (GD25Q127CSIG) - RAM: 256 MB - WLAN: 2.4 GHz, 5 GHz (MediaTek MT7615DN) - Ethernet: 4x 10/100/1000 Mbps - SFP cage (using RTL8211FS-CG) - USB 3.0 port - Power: 12 VDC, 2 A Flash instruction via TFTP: 1. Boot SNR-CPE-ME2 to recovery mode (press reset button and power on device, hold button for ~10 seconds) 2. Send firmware via TFTP client: TFTP Server address: 192.168.1.1 TFTP Client address: 192.168.1.131 3. Wait ~120 seconds to complete flashing 4. Do sysupgrade using web-interface MAC Addresses(stock) -------------------- +----------+------------------+-------------------+ | use | address | example | +----------+------------------+-------------------+ | Device | label | 6A:C4:DD:xx:xx:28 | | Ethernet | + 1 | 6A:C4:DD:xx:xx:29 | | 2g | + 2 | 6A:C4:DD:xx:xx:2A | | 5g | + 3 | 6A:C4:DD:xx:xx:2B | +----------+------------------+-------------------+ Notes: - Reading sfp eeprom is not supported [1] (driver issue). Stock image has the same situation. References: 1. https://forum.openwrt.org/t/mt7621-and-reading-sfp-eeprom/152249 Signed-off-by: Aleksey Nasibulin <alealexpro100@ya.ru>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 78ad0e5c09..a88f00e677 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -1963,6 +1963,18 @@ define Device/snr_snr-cpe-me2-lite
endef
TARGET_DEVICES += snr_snr-cpe-me2-lite
+define Device/snr_snr-cpe-me2-sfp
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := SNR
+ DEVICE_MODEL := SNR-CPE-ME2-SFP
+ UIMAGE_NAME := $$(DEVICE_MODEL)
+ DEVICE_PACKAGES := kmod-mt7615-firmware kmod-usb3 \
+ kmod-sfp kmod-usb-ledtrig-usbport uboot-envtools
+endef
+TARGET_DEVICES += snr_snr-cpe-me2-sfp
+
define Device/storylink_sap-g3200u3
$(Device/dsa-migration)
IMAGE_SIZE := 7872k