aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorArınç ÜNAL <arinc.unal@arinc9.com>2023-03-29 13:11:30 +0300
committerHauke Mehrtens <hauke@hauke-m.de>2023-05-18 14:44:07 +0200
commitce1f9fa625ab7d2159b90d76df5030a55a3de419 (patch)
treec459ebb9a5afcf0e02f33978e56df5d103c35796 /target/linux/ramips/image
parentc42847989eae6ec6fb9762163871291079cb609e (diff)
downloadupstream-ce1f9fa625ab7d2159b90d76df5030a55a3de419.tar.gz
upstream-ce1f9fa625ab7d2159b90d76df5030a55a3de419.tar.bz2
upstream-ce1f9fa625ab7d2159b90d76df5030a55a3de419.zip
ramips: add support for TOZED ZLT S12 PRO
The TOZED ZLT S12 PRO is an AC1200 router featuring 4 Ethernet ports with a TOZED TL70-C cellular modem which supports the NCM mode. The stock firmware does SIM locking on the modem by stopping dialing when a different PLMN is detected. This is not the case on OpenWrt. Specifications: - CPU: MediaTek MT7621AT - RAM: 256MB DDR3 - NOR Flash: MX25L12833FM2I 16MB SPI Flash - Wi-Fi 2.4Ghz: MT7603E - Wi-Fi 5Ghz: MT7612E - Switch: MT7530 4x 1Gbit Ports - WWAN: Unisoc SL8563 based TOZED TL70-C LTE CAT6 cellular modem - USB: 1x optional USB2.0 external port - Switches/Buttons: WPS, Reset, Power Switch - LEDs: Power, Wi-Fi, Data, Signal 1-5, Phone Installation and TFTP Recovery: - Connect to serial console. - Boot initramfs image by choosing option 1 when U-Boot prompts. - Install sysupgrade image via OpenWrt. Serial Pins: Located at the bottom right when looking from the front, right under the Reset/WPS buttons. The pinout from the left is: - RX - GND - TX Baudrate is 115200. When connecting from a powered off state, disconnect RX as it blocks the boot process. Link: http://www.sztozed.com/en/contents/58/84.html Co-developed-by: Andre Cruz <me@1conan.com> Signed-off-by: Andre Cruz <me@1conan.com> Signed-off-by: Arınç ÜNAL <arinc.unal@arinc9.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index fc532966c8..f717fea5d4 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -2135,6 +2135,16 @@ define Device/totolink_x5000r
endef
TARGET_DEVICES += totolink_x5000r
+define Device/tozed_zlt-s12-pro
+ $(Device/dsa-migration)
+ $(Device/uimage-lzma-loader)
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := TOZED
+ DEVICE_MODEL := ZLT S12 PRO
+ DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 comgt-ncm -uboot-envtools
+endef
+TARGET_DEVICES += tozed_zlt-s12-pro
+
define Device/tplink_archer-ax23-v1
$(Device/dsa-migration)
$(Device/tplink-safeloader)