aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-09 10:32:37 +0000
committerJohn Crispin <john@openwrt.org>2015-04-09 10:32:37 +0000
commitb7f19a5b261966a6fc2a587ea43c1dd6aa189a55 (patch)
tree5cb8af5935dbe6b65a824b978bc21966139ce97d /target/linux/ramips/image
parentb757a9971a811749930eb6734f9ab2bbb8113c25 (diff)
downloadupstream-b7f19a5b261966a6fc2a587ea43c1dd6aa189a55.tar.gz
upstream-b7f19a5b261966a6fc2a587ea43c1dd6aa189a55.tar.bz2
upstream-b7f19a5b261966a6fc2a587ea43c1dd6aa189a55.zip
ramips: Add support for Microduino MicroWRT
MicroWRT is an wireless router with 2 USB,1 ethernet port. It has a 16M flash and 64M DDR2 RAM. You can use most interface, such as i2c, SPI, i2s and PCIe. Besides that there are three expansion borad to combine with the core board. The detailed information, please refer to https://www.microduino.cc/wiki/index.php?title=Main_Page This patch adds support for it. Because there is only one port,so disabled VLAN and use eth0 as lan port. and only a power LED control by power pin. Signed-off-by: 盛凯 <shengkai81@gmail.com> SVN-Revision: 45331
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 743f7b4cf6..e6b5112d3e 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -865,6 +865,8 @@ Image/Build/Profile/XIAOMI-MIWIFI-MINI=$(call BuildFirmware/Default16M/$(1),$(1)
Image/Build/Profile/ZTE-Q7=$(call BuildFirmware/Default8M/$(1),$(1),zte-q7,ZTE-Q7)
Image/Build/Profile/ZBT-WA05=$(call BuildFirmware/Default8M/$(1),$(1),zbt-wa05,ZBT-WA05)
Image/Build/Profile/ArcherC20i=$(call BuildFirmware/Tplink/$(1),$(1),ArcherC20i,ArcherC20i)
+microwrt_mtd_size=16515072
+Image/Build/Profile/MicroWRT=$(call BuildFirmware/CustomFlash/$(1),$(1),microwrt,MicroWRT,$(microwrt_mtd_size))
ifeq ($(SUBTARGET),mt7620)
@@ -895,6 +897,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/ZTE-Q7,$(1))
$(call Image/Build/Profile/ZBT-WA05,$(1))
$(call Image/Build/Profile/ArcherC20i,$(1))
+ $(call Image/Build/Profile/MicroWRT,$(1))
endef
endif