aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorThomas Aldrian <dev.aldrian@gmail.com>2021-11-02 19:10:39 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2021-11-20 21:08:25 +0100
commitb28443f82e4d83226a47f7b0d7ced06dff4f3350 (patch)
tree716909c429a5abc66ef8ec402fcd3ce1cb4926e0 /target/linux/ramips/image
parent0e96e068672ee09e90c57c6b6cd0fc2c83d59868 (diff)
downloadupstream-b28443f82e4d83226a47f7b0d7ced06dff4f3350.tar.gz
upstream-b28443f82e4d83226a47f7b0d7ced06dff4f3350.tar.bz2
upstream-b28443f82e4d83226a47f7b0d7ced06dff4f3350.zip
ramips: add support for Wavlink WL-WN576A2
This commit adds support for the Wavlink WL-WN576A2 wall-plug wireles repeater / router. It is also sold under the name SilverCrest SWV 733 B1. Device specs: - CPU: MediaTek MT7628AN - Flash: 8MB - RAM: 64MB - Bootloader: U-Boot - Ethernet: 1x 10/100 Mbps - 2.4 GHz: b/g/n SoC - 5 GHz: a/n/ac MT7610EN - Buttons: WPS, reset, sliding switch (ap/repeater) - LEDs: 5x wifi status, 1x LAN/WAN, 1x WPS Flashing: U-Boot launches a TFTP client if WPS button is held during boot. - Server IP: 192.168.10.100 - Firmware file name: firmware.bin Device will reboot automatically. First boot takes about 90s. Coelner (waenger@gmail.com) is the original author, but I have made some fixes. He does not wish to sign off using his real name. Signed-off-by: Thomas Aldrian <dev.aldrian@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt76x8.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 7d28cd62e8..e9188e7405 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -758,6 +758,16 @@ define Device/wavlink_wl-wn575a3
endef
TARGET_DEVICES += wavlink_wl-wn575a3
+define Device/wavlink_wl-wn576a2
+ IMAGE_SIZE := 7872k
+ DEVICE_VENDOR := Wavlink
+ DEVICE_MODEL := WL-WN576A2
+ DEVICE_ALT0_VENDOR := Silvercrest
+ DEVICE_ALT0_MODEL := SWV 733 B1
+ DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += wavlink_wl-wn576a2
+
define Device/wavlink_wl-wn577a2
IMAGE_SIZE := 7872k
DEVICE_VENDOR := Wavlink