aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJan Hoffmann <jan@3e8.eu>2020-06-26 23:46:19 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-06-27 00:33:29 +0200
commitb1d5ab1a698b05d7522df029a85f8078ee4217af (patch)
treea378fed31672d6fe7f55c1c9daf114314bb32a76 /target/linux/ramips/image
parentbd49f2c9848ec10c7c7b41eaa14ac6c26e2bc977 (diff)
downloadupstream-b1d5ab1a698b05d7522df029a85f8078ee4217af.tar.gz
upstream-b1d5ab1a698b05d7522df029a85f8078ee4217af.tar.bz2
upstream-b1d5ab1a698b05d7522df029a85f8078ee4217af.zip
ramips: add support for NETGEAR WAC124
The WAC124 hardware appears to be identical to R6260/R6350/R6850. SoC: MediaTek MT7621AT RAM: 128M DDR3 FLASH: 128M NAND (Macronix MX30LF1G18AC) WiFI: MediaTek MT7603 bgn 2T2R MediaTek MT7615 nac 4T4R ETH: SoC Integrated Gigabit Switch (1x WAN, 4x LAN) USB: 1x USB 2.0 BTN: Reset, WPS LED: Power, Internet, WiFi, USB (all green) Installation: The factory image can be flashed from the stock firmware web interface or using nmrpflash. With nmrpflash it is also possible to revert to stock firmware. Signed-off-by: Jan Hoffmann <jan@3e8.eu>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index d6423f81d9..de20934598 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -702,6 +702,18 @@ define Device/netgear_wac104
endef
TARGET_DEVICES += netgear_wac104
+define Device/netgear_wac124
+ $(Device/netgear_sercomm_nand)
+ DEVICE_MODEL := WAC124
+ SERCOMM_HWNAME := WAC124
+ SERCOMM_HWID := CTL
+ SERCOMM_HWVER := A003
+ SERCOMM_SWVER := 0x0402
+ IMAGE_SIZE := 40960k
+ DEVICE_PACKAGES += kmod-mt7615e kmod-mt7615-firmware
+endef
+TARGET_DEVICES += netgear_wac124
+
define Device/netgear_wndr3700-v5
$(Device/uimage-lzma-loader)
BLOCKSIZE := 64k