aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorKyson Lok <kysonlok@gmail.com>2017-05-17 18:18:45 +0800
committerMathias Kresin <dev@kresin.me>2017-05-26 08:04:15 +0200
commitabbfcc85259a4f6658c61e99dd3d2d3567e3eb3a (patch)
tree005f2cb004e90efa6868b0c736edcfea265a5f92 /target/linux/ramips/image
parentda472e5b30f63b7f214b1d646ef0d955cbf3f295 (diff)
downloadupstream-abbfcc85259a4f6658c61e99dd3d2d3567e3eb3a.tar.gz
upstream-abbfcc85259a4f6658c61e99dd3d2d3567e3eb3a.tar.bz2
upstream-abbfcc85259a4f6658c61e99dd3d2d3567e3eb3a.zip
ramips: add support for GL-inet GL-MT300N-V2
This patch adds supports for the GL-inet GL-MT300N-V2. Specification: - SoC: MediaTek MT7628AN - Flash: 16 MiB (W25Q128FVSG) - RAM: 128 MiB DDR - Ethernet: 1 x WAN (100 Mbps) and 1 x LAN (100 Mbps) - USB: 1 x USB 2.0 port - Button: 1 x switch button, 1 x reset button - LED: 3 x LEDS (system power led is not GPIO controller) - UART: 1 x UART on PCB (JP1: 3.3V, RX, TX, GND) Installation through Luci: - The original firmware is LEDE, so both LuCI or sysupgrade can be used. - Do not keep settings, for sysupgrade please use the -n option. Installation through bootloader webserver: - Plug power and hold reset button until red LED blink to bright. - Install sysupgrade image using web interface on 192.168.1.1. Signed-off-by: Kyson Lok <kysonlok@gmail.com> [match maximum image size with firmware partition] Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7628.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7628.mk b/target/linux/ramips/image/mt7628.mk
index 6bb04ea38c..f8bd2c18b2 100644
--- a/target/linux/ramips/image/mt7628.mk
+++ b/target/linux/ramips/image/mt7628.mk
@@ -26,6 +26,14 @@ define Device/miwifi-nano
endef
TARGET_DEVICES += miwifi-nano
+define Device/gl-mt300n-v2
+ DTS := GL-MT300N-V2
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := GL-iNet GL-MT300N-V2
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += gl-mt300n-v2
+
define Device/vocore2
DTS := VOCORE2
IMAGE_SIZE := $(ralink_default_fw_size_16M)