aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-08-01 14:30:46 +0000
committerJohn Crispin <john@openwrt.org>2013-08-01 14:30:46 +0000
commitaaedf6c8c612d0a561c91fd0f11631ff7e9576b1 (patch)
tree69c119f2f70628e25e3a88dfb4cac459bb36f22e /target/linux/ramips/image
parentb4c722267e206bd00856b98ce022ee64afa6568c (diff)
downloadupstream-aaedf6c8c612d0a561c91fd0f11631ff7e9576b1.tar.gz
upstream-aaedf6c8c612d0a561c91fd0f11631ff7e9576b1.tar.bz2
upstream-aaedf6c8c612d0a561c91fd0f11631ff7e9576b1.zip
ramips: add basics for Poray devices
This commit adds the basic elements to support Poray brand routers. It contains a tool to do the encryption/obfuscation that is used in Poray routers. Support for Poray devices was worked on by: Felix Kaechele <heffer@fedoraproject.org> Luis Soltero <lsoltero@globalmarinenet.com> Michel Stempin <michel.stempin@wanadoo.fr> Signed-off-by: Felix Kaechele <heffer@fedoraproject.org> SVN-Revision: 37635
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 4d841b96ce..1a134e6ba2 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -215,6 +215,42 @@ define BuildFirmware/dap1350/squashfs
endef
BuildFirmware/dap1350/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
+# Sign Poray images
+define BuildFirmware/Poray4M/squashfs
+ $(call BuildFirmware/Default4M/$(1),$(1),$(2),$(3))
+ if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+ mkporayfw -B $(3) -F 4M \
+ -f $(call sysupname,$(1),$(2)) \
+ -o $(call imgname,$(1),$(2))-factory.bin; \
+ fi
+endef
+BuildFirmware/Poray4M/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
+
+define BuildFirmware/Poray8M/squashfs
+ $(call BuildFirmware/Default8M/$(1),$(1),$(2),$(3))
+ if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+ mkporayfw -B $(3) -F 8M \
+ -f $(call sysupname,$(1),$(2)) \
+ -o $(call imgname,$(1),$(2))-factory.bin; \
+ fi
+endef
+BuildFirmware/Poray8M/initramfs=$(call BuildFirmware/OF/initramfs,$(1),$(2),$(3))
+
+define BuildFirmware/PorayDualSize/squashfs
+ $(call BuildFirmware/DefaultDualSize/$(1),$(1),$(2),$(3))
+ if [ -e "$(call sysupname,$(1),$(2)-4M)" ]; then \
+ mkporayfw -B $(3) -F 4M \
+ -f $(call sysupname,$(1),$(2)-4M) \
+ -o $(call imgname,$(1),$(2))-4M-factory.bin; \
+ fi
+ if [ -e "$(call sysupname,$(1),$(2)-8M)" ]; then \
+ mkporayfw -B $(3) -F 8M \
+ -f $(call sysupname,$(1),$(2)-8M) \
+ -o $(call imgname,$(1),$(2))-8M-factory.bin; \
+ fi
+endef
+BuildFirmware/PorayDualSize/initramfs=$(call BuildFirmware/DefaultDualSize/initramfs,$(1),$(2),$(3))
+
#
# RT288X Profiles
#