aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorShiji Yang <yangshiji66@qq.com>2021-07-27 12:32:00 +0800
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-08-25 01:42:16 +0200
commita73a8269e13f9387a2ac883dac7fe0dd49999ede (patch)
tree73043eb7797da007df192b8d68f5f07cad52e01f /target/linux/ramips/image
parent09143282bde3abd560a3b70f76df6d77b6ac6f12 (diff)
downloadupstream-a73a8269e13f9387a2ac883dac7fe0dd49999ede.tar.gz
upstream-a73a8269e13f9387a2ac883dac7fe0dd49999ede.tar.bz2
upstream-a73a8269e13f9387a2ac883dac7fe0dd49999ede.zip
ramips: add support for DomyWifi DM202/DM203/DW22D
Specifications: * SOC: MT7620A + MT7610E * ROM: 16 MiB spi flash (W25Q128FVSG) * RAM: 128 MiB DDR2 (W971GG6KB-25) * WAN: 10/100M *1 * LAN: 10/100M *4 * USB: Type-A USB2.0 *1 * SD: MicroSD *1 * Button: Reset *1 * Antennas: 2.4 GHz *2 + 5 GHz *1 * TTL Baudrate: 57600 * U-Boot Recovery: IP: 10.10.10.123, Server: 10.10.10.3 Installation: * Web UI Update 1. Open http://192.168.10.1/upgrade.html in the browser. 2. Rename firmware to a short name like firmware.bin and then upload it. 3. Fill in the password column with the following content: password | mtd -x mIp2osnRG3qZGdIlQPh1 -r write /tmp/firmware.bin firmware * TFTP + U-Boot 1. Connect device with a TTL cable. 2. Press "2" when booting to select "Load system code then write to Flash via TFTP". 3. Upload firmware by tftpd64, it will boot when write instruction is executed. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7620.mk27
1 files changed, 27 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index bfc7fa7db0..86751aad31 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -308,6 +308,33 @@ define Device/dlink_dwr-960
endef
TARGET_DEVICES += dlink_dwr-960
+define Device/domywifi_dm202
+ SOC := mt7620a
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := DomyWifi
+ DEVICE_MODEL := DM202
+ DEVICE_PACKAGES := kmod-mt76x0e kmod-sdhci-mt7620 kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += domywifi_dm202
+
+define Device/domywifi_dm203
+ SOC := mt7620a
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := DomyWifi
+ DEVICE_MODEL := DM203
+ DEVICE_PACKAGES := kmod-mt76x0e kmod-sdhci-mt7620 kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += domywifi_dm203
+
+define Device/domywifi_dw22d
+ SOC := mt7620a
+ IMAGE_SIZE := 16064k
+ DEVICE_VENDOR := DomyWifi
+ DEVICE_MODEL := DW22D
+ DEVICE_PACKAGES := kmod-mt76x0e kmod-sdhci-mt7620 kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += domywifi_dw22d
+
define Device/dovado_tiny-ac
SOC := mt7620a
IMAGE_SIZE := 7872k