aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorINAGAKI Hiroshi <musashino.open@gmail.com>2020-04-24 14:51:53 +0900
committerDavid Bauer <mail@david-bauer.net>2020-04-27 12:22:02 +0200
commita25bb8610ffb985feb49652ce633a60182a0bd5c (patch)
tree5406f7e2d4dc3117253789b2982943d511b04681 /target/linux/ramips/image
parentce1957100411b0a751d6431d36def9c28048b4dc (diff)
downloadupstream-a25bb8610ffb985feb49652ce633a60182a0bd5c.tar.gz
upstream-a25bb8610ffb985feb49652ce633a60182a0bd5c.tar.bz2
upstream-a25bb8610ffb985feb49652ce633a60182a0bd5c.zip
ramips: use lzma-loader for Japanese mt7621 devices
In several Japanese routers with MT7621 SoC, the official sysupgrade image cannot be booted properly after switching to kernel 5.4. This commit fixes the issue by using lzma-loader. Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 60576eaff5..abaf3efe2b 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -187,6 +187,7 @@ endef
TARGET_DEVICES += asus_rt-ac85p
define Device/buffalo_wsr-1166dhp
+ $(Device/uimage-lzma-loader)
IMAGE/sysupgrade.bin := trx | pad-rootfs | append-metadata
IMAGE_SIZE := 15936k
DEVICE_VENDOR := Buffalo
@@ -197,6 +198,7 @@ endef
TARGET_DEVICES += buffalo_wsr-1166dhp
define Device/buffalo_wsr-2533dhpl
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 7936k
DEVICE_VENDOR := Buffalo
DEVICE_MODEL := WSR-2533DHPL
@@ -286,6 +288,7 @@ endef
TARGET_DEVICES += elecom_wrc-1167ghbk2-s
define Device/elecom_wrc-1900gst
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 11264k
DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-1900GST
@@ -296,6 +299,7 @@ endef
TARGET_DEVICES += elecom_wrc-1900gst
define Device/elecom_wrc-2533gst
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 11264k
DEVICE_VENDOR := ELECOM
DEVICE_MODEL := WRC-2533GST
@@ -356,6 +360,7 @@ endef
TARGET_DEVICES += hiwifi_hc5962
define Device/iodata_wn-ax1167gr
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 15552k
KERNEL_INITRAMFS := $$(KERNEL) | \
iodata-factory 7864320 4 0x1055 $(KDIR)/tmp/$$(KERNEL_INITRAMFS_PREFIX)-factory.bin
@@ -414,6 +419,7 @@ endef
TARGET_DEVICES += iodata_wn-dx1167r
define Device/iodata_wn-gx300gr
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 7616k
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WN-GX300GR
@@ -422,6 +428,7 @@ endef
TARGET_DEVICES += iodata_wn-gx300gr
define Device/iodata_wnpr2600g
+ $(Device/uimage-lzma-loader)
DEVICE_VENDOR := I-O DATA
DEVICE_MODEL := WNPR2600G
IMAGE_SIZE := 13952k
@@ -718,6 +725,7 @@ endef
TARGET_DEVICES += phicomm_k2p
define Device/planex_vr500
+ $(Device/uimage-lzma-loader)
IMAGE_SIZE := 65216k
DEVICE_VENDOR := Planex
DEVICE_MODEL := VR500