aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ramips/image
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2021-08-02 00:43:34 +0900
committerSungbo Eo <mans0n@gorani.run>2022-01-02 00:50:43 +0900
commita1deab0ec9ced8f1a2c997483efc1fc6e364ae34 (patch)
tree0a571179e82c594985e1ba203556164cecdfd573 /target/linux/ramips/image
parent4b587f25614f3f7215360f96807ce760fa4ef3aa (diff)
downloadupstream-a1deab0ec9ced8f1a2c997483efc1fc6e364ae34.tar.gz
upstream-a1deab0ec9ced8f1a2c997483efc1fc6e364ae34.tar.bz2
upstream-a1deab0ec9ced8f1a2c997483efc1fc6e364ae34.zip
ramips: add support for ipTIME T5004
ipTIME T5004 is a 5-port Gigabit Ethernet router, based on MediaTek MT7621A. Specifications: * SoC: MT7621AT * RAM: 128 MiB * Flash: NAND 128 MiB * Ethernet: 5x 1GbE * Switch: SoC built-in * UART: J4 (57600 baud) * Pinout: [3V3] (TXD) (RXD) (GND) Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Revert to stock firmware via recovery mode: 1. Press reset button, power up the device, wait >15s for CPU LED to stop blinking. 2. Upload stock image to TFTP server at 192.168.0.1. Signed-off-by: Sungbo Eo <mans0n@gorani.run>
Diffstat (limited to 'target/linux/ramips/image')
-rw-r--r--target/linux/ramips/image/mt7621.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index e1cb0195b0..99884ec1d9 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -804,6 +804,21 @@ define Device/iptime_a8004t
endef
TARGET_DEVICES += iptime_a8004t
+define Device/iptime_t5004
+ $(Device/dsa-migration)
+ BLOCKSIZE := 128k
+ PAGESIZE := 2048
+ KERNEL_SIZE := 4096k
+ IMAGE_SIZE := 129280k
+ UBINIZE_OPTS := -E 5
+ UIMAGE_NAME := t5004
+ IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+ DEVICE_VENDOR := ipTIME
+ DEVICE_MODEL := T5004
+ DEVICE_PACKAGES := -wpad-basic-wolfssl
+endef
+TARGET_DEVICES += iptime_t5004
+
define Device/jcg_jhr-ac876m
$(Device/dsa-migration)
IMAGE_SIZE := 16064k